aboutsummaryrefslogtreecommitdiff
path: root/lang/luarocks/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-08-15 10:19:27 -0700
committerRosen Penev <rosenp@gmail.com>2019-08-15 10:22:09 -0700
commitb61ca9d885fc323d6d3f0a5a08a6fe09e20e9ad2 (patch)
tree16fd74569bac3dae852616cf90378222d3077050 /lang/luarocks/Makefile
parent3a80fa9cb8a5f700b504921679e6d7485a8467f0 (diff)
luarocks: Add zip/host build dependency
Needed when zip is missing on the host system. Fixed LICENSE information. Added *BUILD_PARALLEL for faster compilation. Other minor cleanups. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'lang/luarocks/Makefile')
-rw-r--r--lang/luarocks/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/lang/luarocks/Makefile b/lang/luarocks/Makefile
index 683bb9e55..25db0325f 100644
--- a/lang/luarocks/Makefile
+++ b/lang/luarocks/Makefile
@@ -3,27 +3,28 @@
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
-#
+#
include $(TOPDIR)/rules.mk
PKG_NAME:=luarocks
PKG_VERSION:=2.2.2
-PKG_RELEASE:=3
+PKG_RELEASE:=4
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_MIRROR_HASH:=e4cf874c9bce34a5accd41daaf51a3213763b8b6f7f658ca4d13a70a7ddb1c0c
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_URL:=https://github.com/keplerproject/luarocks.git
+PKG_SOURCE_URL:=https://github.com/keplerproject/luarocks
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
+PKG_MIRROR_HASH:=e4cf874c9bce34a5accd41daaf51a3213763b8b6f7f658ca4d13a70a7ddb1c0c
PKG_MAINTAINER:=Amr Hassan <amr.hassan@gmail.com>
-PKG_INSTALL=1
-PKG_BUILD_DEPENDS:=lua/host
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=COPYING
+
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+PKG_BUILD_DEPENDS:=lua/host zip/host
HOST_BUILD_DEPENDS:=$(PKG_BUILD_DEPENDS)
-PKG_LICENSE=GPL
-HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-$(PKG_VERSION)
+HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/package.mk