aboutsummaryrefslogtreecommitdiff
path: root/lang/luarocks/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-05-01 08:14:30 +0200
committerNicolas Thill <nico@openwrt.org>2015-05-01 08:14:30 +0200
commita1bd5565d0a3435b75bcab1c34edd21d57ed2646 (patch)
treeb43516a0f160b4c73b8f7fd6159223fe4047b1ed /lang/luarocks/Makefile
parenta2c782c6f0a50cef855d73a886eb491c9d0e9a87 (diff)
luarocks: don't use github conflicting tag archives (#1051)
Signed-off-by: Nicolas Thill <nico@openwrt.org>
Diffstat (limited to 'lang/luarocks/Makefile')
-rw-r--r--lang/luarocks/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/lang/luarocks/Makefile b/lang/luarocks/Makefile
index 15643ff5d..3aae8e9e9 100644
--- a/lang/luarocks/Makefile
+++ b/lang/luarocks/Makefile
@@ -11,8 +11,12 @@ PKG_NAME:=luarocks
PKG_VERSION:=2.2.0-rc1
PKG_RELEASE:=2
-PKG_SOURCE:=v$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://github.com/keplerproject/$(PKG_NAME)/archive/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=https://github.com/keplerproject/luarocks.git
+PKG_SOURCE_VERSION:=v$(PKG_VERSION)
+
PKG_MAINTAINER:=Amr Hassan <amr.hassan@gmail.com>
PKG_INSTALL=1
PKG_BUILD_DEPENDS:=lua/host luac/host