aboutsummaryrefslogtreecommitdiff
path: root/lang/luaposix/Makefile
diff options
context:
space:
mode:
authorMaxim Storchak <m.storchak@gmail.com>2015-06-19 20:14:33 +0300
committerMaxim Storchak <m.storchak@gmail.com>2015-06-22 14:56:30 +0300
commit76b5c2007dd9bd441841895a50827fd72b86188c (patch)
treebd30bc4d08bd1f639c0b14b8329dba8efd54faee /lang/luaposix/Makefile
parent2865b5aa09873cc68c1050bb6a4ad1e0b58f1d39 (diff)
luaposix: fix compatibility with musl
Signed-off-by: Maxim Storchak <m.storchak@gmail.com>
Diffstat (limited to 'lang/luaposix/Makefile')
-rw-r--r--lang/luaposix/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/lang/luaposix/Makefile b/lang/luaposix/Makefile
index 40cddc054..a189e6645 100644
--- a/lang/luaposix/Makefile
+++ b/lang/luaposix/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=luaposix
PKG_VERSION:=v33.2.1
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE:=release-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/luaposix/luaposix/archive/
@@ -41,6 +41,9 @@ endef
CONFIGURE_VARS += ac_cv_path_LDOC=""
TARGET_CFLAGS += -DLUA_USE_LINUX $(FPIC) -std=gnu99
+ifeq ($(CONFIG_USE_MUSL),y)
+ TARGET_CFLAGS += -D_POSIX_PRIORITY_SCHEDULING
+endif
ifneq ($(CONFIG_USE_GLIBC),)
ifeq ($(CONFIG_EGLIBC_OPTION_EGLIBC_UTMP),)