aboutsummaryrefslogtreecommitdiff
path: root/lang/lualanes/Makefile
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2017-01-10 15:02:50 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2017-01-10 18:25:54 +0100
commit4a984a8d60f167db87dac6a6c283e62aca692d5e (patch)
treee0e6f0bcbe5094d62a80018c3d7557e3efe219ac /lang/lualanes/Makefile
parent876d139c98a822f04aed2767b08638cd6efd0a45 (diff)
treewide: replace $(STAGING_DIR)/host and $(HOST_BUILD_PREFIX) with $(STAGING_DIR_HOSTPKG)
As both LEDE and OpenWrt have STAGING_DIR_HOSTPKG now, we can start to rely on it. See 73b7f55424de52d8179a9ad808252fe3bf8dcc9d for more information on STAGING_DIR_HOSTPKG. STAGING_DIR_HOSTPKG won't actually be changed before the first LEDE release (it is equivalent to $(STAGING_DIR)/host), so this simple search/replace cleanup is safe to apply. Doing this cleanup now will be useful for the Gluon project (an OpenWrt/LEDE based firmware framework) for experimenting with modifying STAGING_DIR_HOSTPKG before doing this in the LEDE upstream. Also fixes a typo in the dbus Makefile ("STAGIND_DIR"). Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'lang/lualanes/Makefile')
-rw-r--r--lang/lualanes/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/lualanes/Makefile b/lang/lualanes/Makefile
index 616129066..749709d99 100644
--- a/lang/lualanes/Makefile
+++ b/lang/lualanes/Makefile
@@ -42,8 +42,8 @@ endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) all \
CC="$(TARGET_CC)" \
- LUA="$(STAGING_DIR)/host/bin/lua" \
- LUAC="$(STAGING_DIR)/host/bin/luac" \
+ LUA="$(STAGING_DIR_HOSTPKG)/bin/lua" \
+ LUAC="$(STAGING_DIR_HOSTPKG)/bin/luac" \
OPT_FLAGS="$(TARGET_CFLAGS) --std=c99 -Dpthread_yield=sched_yield"
endef