aboutsummaryrefslogtreecommitdiff
path: root/lang/luajit/Makefile
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2019-05-21 12:55:00 +0100
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2019-05-21 14:59:31 +0100
commit9543d1d1b7694afb3dd0934b5c4a6405c6ba6086 (patch)
tree3166bf4819f8083733252ec8037f07f699618ada /lang/luajit/Makefile
parenta532909c101d4e1c70f9836dfc7e6c4642afdc1b (diff)
luajit: permit building on macos host
luajit didn't understand completely that it was building in a cross compiled environment for Linux target. This would cause issues when building under openwrt on macos. Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Diffstat (limited to 'lang/luajit/Makefile')
-rw-r--r--lang/luajit/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/lang/luajit/Makefile b/lang/luajit/Makefile
index e1f2a7477..72073dd7a 100644
--- a/lang/luajit/Makefile
+++ b/lang/luajit/Makefile
@@ -43,12 +43,14 @@ define Build/Compile
CROSS="$(TARGET_CROSS)" \
DPREFIX=$(PKG_INSTALL_DIR)/usr \
PREFIX=/usr \
+ TARGET_SYS=Linux \
TARGET_CFLAGS="$(TARGET_CFLAGS)"
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
DPREFIX=$(PKG_INSTALL_DIR)/usr \
PREFIX=/usr \
+ TARGET_SYS=Linux \
install
endef