aboutsummaryrefslogtreecommitdiff
path: root/lang/luajit/Makefile
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2023-09-25 00:47:54 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-09-25 17:42:02 +0200
commit5eea661fdb797462412530a07e73c27e57eb8677 (patch)
tree4fe46fe1668af1385c87c6368f71cd2382d3c3ac /lang/luajit/Makefile
parentc8a84f65f1c58f94a151742a95fb73989fb13c77 (diff)
luajit: move arch dependency to dedicated config HAS_LUAJIT_ARCH
Move arch dependency for luajit to dedicated config HAS_LUAJIT_ARCH to workaround recursive dependency limitation. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'lang/luajit/Makefile')
-rw-r--r--lang/luajit/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/lang/luajit/Makefile b/lang/luajit/Makefile
index 3ce1555b6..78b9726d5 100644
--- a/lang/luajit/Makefile
+++ b/lang/luajit/Makefile
@@ -24,12 +24,19 @@ define Package/luajit
CATEGORY:=Languages
TITLE:=LuaJIT
URL:=https://www.luajit.org
- DEPENDS:=@(i386||x86_64||arm||armeb||aarch64||powerpc||mips||mipsel||mips64)
+ DEPENDS:=@HAS_LUAJIT_ARCH
endef
define Package/luajit/description
LuaJIT is a Just-In-Time (JIT) compiler for the Lua programming language. *** Requires GCC Multilib on host system to build! ***
endef
+
+define Package/luajit/config
+config HAS_LUAJIT_ARCH
+ bool
+ default y if i386||x86_64||arm||armeb||aarch64||powerpc||mips||mipsel||mips64
+endef
+
ifeq ($(HOST_ARCH),$(filter $(HOST_ARCH), x86_64 mips64))
ifeq ($(CONFIG_ARCH_64BIT),)
HOST_BITS := -m32