aboutsummaryrefslogtreecommitdiff
path: root/lang/luajit/Makefile
diff options
context:
space:
mode:
authorEric Kinzie <ekinzie@labn.net>2019-06-11 13:52:17 -0400
committerEric Kinzie <ekinzie@labn.net>2019-06-11 17:24:19 -0400
commit5b0ef0e1b96ac25dd340ac65cb1b54c8f86924ac (patch)
tree8013e4ae228c61c62bac7aa315d26d32af853d2d /lang/luajit/Makefile
parent5d34dd284a48fbf75eaa7c66e91c446de48b069a (diff)
luajit: fix building for 64-bit targets
Host and target architectures need to have the same pointer size. When building on x86_64, do not force 32-bit host binaries if the target architecture is also 64-bit. See http://luajit.org/install.html#cross Add 64-bit arm (aarch64) to the list of architectures. Signed-off-by: Eric Kinzie <ekinzie@labn.net>
Diffstat (limited to 'lang/luajit/Makefile')
-rw-r--r--lang/luajit/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/lang/luajit/Makefile b/lang/luajit/Makefile
index 72073dd7a..296a3ebb6 100644
--- a/lang/luajit/Makefile
+++ b/lang/luajit/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=luajit
PKG_VERSION:=2.1.0-beta3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=LuaJIT-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://luajit.org/download
@@ -24,7 +24,7 @@ define Package/luajit
CATEGORY:=Languages
TITLE:=LuaJIT
URL:=https://www.luajit.org
- DEPENDS:=@(i386||x86_64||arm||armeb||powerpc||mips||mipsel)
+ DEPENDS:=@(i386||x86_64||arm||armeb||aarch64||powerpc||mips||mipsel)
endef
define Package/luajit/description
@@ -32,7 +32,7 @@ define Package/luajit/description
endef
ifeq ($(HOST_ARCH),x86_64)
- ifeq ($(CONFIG_x86_64),)
+ ifeq ($(CONFIG_ARCH_64BIT),)
HOST_BITS := -m32
endif
endif