aboutsummaryrefslogtreecommitdiff
path: root/lang/lua-rings
diff options
context:
space:
mode:
authorDirk Chang <dirk@kooiot.com>2015-04-27 20:34:27 +0800
committerDirk Chang <dirk@kooiot.com>2015-04-27 20:34:27 +0800
commitb3817517526a39d5062dfb58e961eb15a5fbe853 (patch)
tree85b890f9b8b3f99b948afeb930f465dcbb12ea22 /lang/lua-rings
parent426d1f12d152ffdc71c57cd59e21c8f62c198a7b (diff)
Added a few lua modules (lpeg, md5, cjson, copas, coxpcall, lzlib, rings, rs232, wsapi, xavante, lzmq, mobdebug), zeromq
Signed-off-by: Dirk Chang <dirk@kooiot.com>
Diffstat (limited to 'lang/lua-rings')
-rw-r--r--lang/lua-rings/Makefile54
-rw-r--r--lang/lua-rings/patches/config.patch28
-rw-r--r--lang/lua-rings/patches/makefile.patch11
3 files changed, 93 insertions, 0 deletions
diff --git a/lang/lua-rings/Makefile b/lang/lua-rings/Makefile
new file mode 100644
index 000000000..9b39c96be
--- /dev/null
+++ b/lang/lua-rings/Makefile
@@ -0,0 +1,54 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lua-rings
+PKG_VERSION:=1.3.0
+PKG_RELEASE:=1
+PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
+PKG_LICENSE:=MIT
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/keplerproject/rings.git
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_VERSION:=2b8a900f8b9dbde304859a3ac9d437795c3fdde3
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+
+PKG_FIXUP:=autoreconf
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/lua-rings
+ SUBMENU:=Lua
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Lua-Rings
+ URL:=http://www.inf.puc-rio.br/~roberto/lua-rings/
+ DEPENDS:=+lua
+endef
+
+define Package/lua-rings/description
+ Rings is a library which provides a way to create new Lua states from within Lua.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+# add make variable overrides here
+MAKE_FLAGS +=
+
+define Build/Configure
+endef
+
+define Package/lua-rings/install
+ $(INSTALL_DIR) $(1)/usr/lib/lua
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/rings.so $(1)/usr/lib/lua
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/src/stable.lua $(1)/usr/lib/lua
+endef
+
+$(eval $(call BuildPackage,lua-rings))
diff --git a/lang/lua-rings/patches/config.patch b/lang/lua-rings/patches/config.patch
new file mode 100644
index 000000000..5740faea9
--- /dev/null
+++ b/lang/lua-rings/patches/config.patch
@@ -0,0 +1,28 @@
+--- lua-rings-1.3.0_org/config 2014-06-04 15:24:24.223662038 +0800
++++ lua-rings-1.3.0/config 2014-06-04 16:16:15.183594040 +0800
+@@ -1,15 +1,15 @@
+ # Installation directories
+
+ # Default prefix
+-PREFIX ?= /usr/local
++PREFIX ?= /usr
+
+ DESTDIR ?= /
+
+ # System's libraries directory (where binary libraries are installed)
+-LUA_LIBDIR ?= $(PREFIX)/lib/lua/5.1
++LUA_LIBDIR ?= $(PREFIX)/lib/lua
+
+ # System's lua directory (where Lua libraries are installed)
+-LUA_DIR ?= $(PREFIX)/share/lua/5.1
++LUA_DIR ?= $(PREFIX)/lib/lua
+
+ # Lua includes directory
+ LUA_INC ?= $(PREFIX)/include
+@@ -24,6 +24,5 @@
+ WARN ?= -O2 -Wall -fPIC -W -Waggregate-return -Wcast-align -Wmissing-prototypes -Wnested-externs -Wshadow -Wwrite-strings -Wpointer-arith -pedantic
+ INCS ?= -I$(LUA_INC)
+ CFLAGS ?= $(WARN) $(INCS)
+-CC ?= gcc
+
+ # $Id: config,v 1.7 2007/10/29 22:51:39 carregal Exp $
diff --git a/lang/lua-rings/patches/makefile.patch b/lang/lua-rings/patches/makefile.patch
new file mode 100644
index 000000000..8bb055120
--- /dev/null
+++ b/lang/lua-rings/patches/makefile.patch
@@ -0,0 +1,11 @@
+--- lua-rings-1.3.0_org/Makefile 2014-06-04 15:24:37.583661746 +0800
++++ lua-rings-1.3.0/Makefile 2014-06-04 15:23:41.611662970 +0800
+@@ -3,6 +3,8 @@
+ T= rings
+ CONFIG= ./config
+
++CFLAGS+= -fPIC
++
+ include $(CONFIG)
+
+ SRCS= src/rings.c