aboutsummaryrefslogtreecommitdiff
path: root/lang/lua-mobdebug
diff options
context:
space:
mode:
authorDirk Chang <dirk@kooiot.com>2015-04-27 20:34:27 +0800
committerDirk Chang <dirk@kooiot.com>2015-04-27 20:34:27 +0800
commitb3817517526a39d5062dfb58e961eb15a5fbe853 (patch)
tree85b890f9b8b3f99b948afeb930f465dcbb12ea22 /lang/lua-mobdebug
parent426d1f12d152ffdc71c57cd59e21c8f62c198a7b (diff)
Added a few lua modules (lpeg, md5, cjson, copas, coxpcall, lzlib, rings, rs232, wsapi, xavante, lzmq, mobdebug), zeromq
Signed-off-by: Dirk Chang <dirk@kooiot.com>
Diffstat (limited to 'lang/lua-mobdebug')
-rw-r--r--lang/lua-mobdebug/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/lang/lua-mobdebug/Makefile b/lang/lua-mobdebug/Makefile
new file mode 100644
index 000000000..3d11539d9
--- /dev/null
+++ b/lang/lua-mobdebug/Makefile
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lua-mobdebug
+PKG_VERSION:=0.61
+PKG_RELEASE:=1
+PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
+PKG_LICENSE:=MIT
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/pkulchenko/MobDebug.git
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_VERSION:=9a03aa59696647ba3b7f9ae2f29a9f28532a4feb
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/lua-mobdebug
+ SUBMENU:=Lua
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Lua-MobDebug
+ URL:=https://github.com/pkulchenko/MobDebug
+ DEPENDS:=+lua
+endef
+
+define Package/lua-mobdebug/description
+ MobDebug is a remote debugger for Lua (including Lua 5.1, Lua 5.2, Lua 5.3, and LuaJIT 2.x).
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Build/Install
+endef
+
+# add make variable overrides here
+MAKE_FLAGS +=
+
+define Package/lua-mobdebug/install
+ $(INSTALL_DIR) $(1)/usr/lib/lua
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/src/mobdebug.lua $(1)/usr/lib/lua
+endef
+
+$(eval $(call BuildPackage,lua-mobdebug))