aboutsummaryrefslogtreecommitdiff
path: root/lang/lua-lzlib/Makefile
diff options
context:
space:
mode:
authorDirk Chang <dirk@kooiot.com>2015-04-27 20:34:27 +0800
committerDirk Chang <dirk@kooiot.com>2015-04-27 20:34:27 +0800
commitb3817517526a39d5062dfb58e961eb15a5fbe853 (patch)
tree85b890f9b8b3f99b948afeb930f465dcbb12ea22 /lang/lua-lzlib/Makefile
parent426d1f12d152ffdc71c57cd59e21c8f62c198a7b (diff)
Added a few lua modules (lpeg, md5, cjson, copas, coxpcall, lzlib, rings, rs232, wsapi, xavante, lzmq, mobdebug), zeromq
Signed-off-by: Dirk Chang <dirk@kooiot.com>
Diffstat (limited to 'lang/lua-lzlib/Makefile')
-rw-r--r--lang/lua-lzlib/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/lang/lua-lzlib/Makefile b/lang/lua-lzlib/Makefile
new file mode 100644
index 000000000..4b9468789
--- /dev/null
+++ b/lang/lua-lzlib/Makefile
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lua-lzlib
+PKG_VERSION:=0.4.1
+PKG_RELEASE:=1
+PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
+PKG_LICENSE:=MIT
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/LuaDist/lzlib.git
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_VERSION:=9fa3993bb4504fbbc10511cde141e1c6a48c072d
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/lua-lzlib
+ SUBMENU:=Lua
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Lua zlib binding
+ URL:=http://github.com/LuaDist/lzlib
+ DEPENDS:= +lua +zlib
+endef
+
+define Package/lua-lzlib/description
+ A library to access zlib library functions and also to read/write gzip files using an interface similar to the base io package.
+endef
+
+define Build/Install
+endef
+
+define Package/lua-lzlib/install
+ $(INSTALL_DIR) $(1)/usr/lib/lua
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/zlib.so $(1)/usr/lib/lua/
+
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/gzip.lua $(1)/usr/lib/lua/
+endef
+
+$(eval $(call BuildPackage,lua-lzlib))