aboutsummaryrefslogtreecommitdiff
path: root/lang/lua-coxpcall/Makefile
diff options
context:
space:
mode:
authorDirk Chang <dirk@kooiot.com>2015-04-27 20:34:27 +0800
committerDirk Chang <dirk@kooiot.com>2015-04-27 20:34:27 +0800
commitb3817517526a39d5062dfb58e961eb15a5fbe853 (patch)
tree85b890f9b8b3f99b948afeb930f465dcbb12ea22 /lang/lua-coxpcall/Makefile
parent426d1f12d152ffdc71c57cd59e21c8f62c198a7b (diff)
Added a few lua modules (lpeg, md5, cjson, copas, coxpcall, lzlib, rings, rs232, wsapi, xavante, lzmq, mobdebug), zeromq
Signed-off-by: Dirk Chang <dirk@kooiot.com>
Diffstat (limited to 'lang/lua-coxpcall/Makefile')
-rw-r--r--lang/lua-coxpcall/Makefile59
1 files changed, 59 insertions, 0 deletions
diff --git a/lang/lua-coxpcall/Makefile b/lang/lua-coxpcall/Makefile
new file mode 100644
index 000000000..6ca3ff848
--- /dev/null
+++ b/lang/lua-coxpcall/Makefile
@@ -0,0 +1,59 @@
+#
+# Copyright (C) 2009-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lua-coxpcall
+PKG_VERSION:=1.15.0
+PKG_RELEASE:=1
+PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
+PKG_LICENSE:=MIT
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/keplerproject/coxpcall.git
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_VERSION:=979257892884816c97391dfd7b0a7b30dcc8f479
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/lua-coxpcall
+ SUBMENU:=Lua
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Lua-Coxpcall
+ URL:=https://github.com/keplerproject/coxpcall
+ DEPENDS:=+lua
+endef
+
+define Package/lua-coxpcall/description
+ Coxpcall encapsulates the protected calls with a coroutine based loop,
+ so errors can be dealed without the usual pcall/xpcall issues with coroutines.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+# add make variable overrides here
+MAKE_FLAGS +=
+
+define Build/Configure
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ T="$(BUILD_VARIANT)" \
+ LUA_DIR="$(PKG_INSTALL_DIR)/usr/lib/lua" \
+ install
+endef
+
+define Package/lua-coxpcall/install
+ $(INSTALL_DIR) $(1)/usr/lib/lua
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/src/coxpcall.lua $(1)/usr/lib/lua
+endef
+
+$(eval $(call BuildPackage,lua-coxpcall))