aboutsummaryrefslogtreecommitdiff
path: root/lang/lua-copas
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-11-21 13:04:36 -0800
committerRosen Penev <rosenp@gmail.com>2018-11-27 09:04:10 -0800
commit0c4b76a3bb7021add05e437cfa6e10fe493b48f1 (patch)
tree57c76d9d04dac0e823fdde5e634672ee2b2e9743 /lang/lua-copas
parent131b83de767b352740bffbf929afecb482ac5284 (diff)
lua-copas: Update to 2.0.2
Switched to codeload + other adjustments. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'lang/lua-copas')
-rw-r--r--lang/lua-copas/Makefile19
-rw-r--r--lang/lua-copas/patches/makefile.patch15
2 files changed, 8 insertions, 26 deletions
diff --git a/lang/lua-copas/Makefile b/lang/lua-copas/Makefile
index 314850ec0..527ec5254 100644
--- a/lang/lua-copas/Makefile
+++ b/lang/lua-copas/Makefile
@@ -8,18 +8,18 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=lua-copas
-PKG_VERSION:=2.0.0
+PKG_VERSION:=2.0.2
PKG_RELEASE:=1
+
+PKG_SOURCE:=copas-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/keplerproject/copas/tar.gz/$(PKG_VERSION)?
+PKG_HASH:=1469eaf987513f5a9a0bee345c040c8fa30ca6194bc75ad78171362f9904cf3e
+PKG_BUILD_DIR:=$(BUILD_DIR)/copas-$(PKG_VERSION)
+
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
PKG_LICENSE:=MIT
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MIRROR_HASH:=a47a8b5f6c1cf0d9fff4770a28bf7a3efdd8f37415dde8e02528f3e63f8a7899
-PKG_SOURCE_URL:=https://github.com/keplerproject/copas.git
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=f39a80add9f7c010ac979297652bbaaea0360a27
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-
+PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
@@ -47,9 +47,6 @@ define Build/Compile
install
endef
-# add make variable overrides here
-MAKE_FLAGS +=
-
define Package/lua-copas/install
$(INSTALL_DIR) $(1)/usr/lib/lua
$(INSTALL_DIR) $(1)/usr/lib/lua/copas
diff --git a/lang/lua-copas/patches/makefile.patch b/lang/lua-copas/patches/makefile.patch
deleted file mode 100644
index 10e473403..000000000
--- a/lang/lua-copas/patches/makefile.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- lua-copas-1.2.1_org/Makefile 2014-06-04 16:39:17.451563827 +0800
-+++ lua-copas-1.2.1/Makefile 2014-06-04 16:39:41.115563309 +0800
-@@ -1,10 +1,10 @@
- # $Id: Makefile,v 1.3 2007/10/29 22:50:16 carregal Exp $
-
- # Default prefix
--PREFIX = /usr/local
-+PREFIX ?= $(DESTDIR)/usr
-
- # System's lua directory (where Lua libraries are installed)
--LUA_DIR= $(PREFIX)/share/lua/5.1
-+LUA_DIR= $(PREFIX)/lib/lua
-
- install:
- mkdir -p $(LUA_DIR)/copas