aboutsummaryrefslogtreecommitdiff
path: root/lang/lua-argparse
diff options
context:
space:
mode:
authorVladimir Malyutin <first-leon@yandex.ru>2020-08-29 01:23:27 +0700
committerVladimir Malyutin <first-leon@yandex.ru>2020-08-29 01:23:27 +0700
commit3b7a6bbd76d3a86e18e490eccbbecb07e9856d82 (patch)
tree14f3b5588a2a7d67dddde342ddf6529061e7cb07 /lang/lua-argparse
parent41d9951575fe890fb91f1e3defa1dd0011dc3815 (diff)
lua-argparse: new package
Signed-off-by: Vladimir Malyutin <first-leon@yandex.ru>
Diffstat (limited to 'lang/lua-argparse')
-rw-r--r--lang/lua-argparse/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/lang/lua-argparse/Makefile b/lang/lua-argparse/Makefile
new file mode 100644
index 000000000..18acbeb56
--- /dev/null
+++ b/lang/lua-argparse/Makefile
@@ -0,0 +1,50 @@
+#
+# Copyright (C) 2006-2020 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lua-argparse
+PKG_VERSION:=0.6.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/mpeterv/argparse/tar.gz/$(PKG_VERSION)?
+PKG_HASH:=0eddda29d591536bc7310b99ce7acc3e5e00557f18d6e63ab10d56683e8952f1
+PKG_BUILD_DIR:=$(BUILD_DIR)/argparse-$(PKG_VERSION)
+
+PKG_MAINTAINER:=Vladimir Malyutin <first-leon@yandex.ru>
+PKG_LICENSE:=MIT
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/lua-argparse
+ SUBMENU:=Lua
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=lua-argparse
+ URL:=https://github.com/mpeterv/argparse
+ DEPENDS:=+lua
+ PKGARCH:=all
+endef
+
+define Package/lua-argparse/description
+ Argparse is a feature-rich command line parser for Lua inspired by argparse for Python.
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/lua-argparse/install
+ $(INSTALL_DIR) $(1)/usr/lib/lua
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/src/argparse.lua $(1)/usr/lib/lua/
+
+endef
+
+$(eval $(call BuildPackage,lua-argparse))