aboutsummaryrefslogtreecommitdiff
path: root/lang/lpeg
diff options
context:
space:
mode:
authorDirk Chang <dirk@kooiot.com>2015-04-27 20:34:27 +0800
committerDirk Chang <dirk@kooiot.com>2015-04-27 20:34:27 +0800
commitb3817517526a39d5062dfb58e961eb15a5fbe853 (patch)
tree85b890f9b8b3f99b948afeb930f465dcbb12ea22 /lang/lpeg
parent426d1f12d152ffdc71c57cd59e21c8f62c198a7b (diff)
Added a few lua modules (lpeg, md5, cjson, copas, coxpcall, lzlib, rings, rs232, wsapi, xavante, lzmq, mobdebug), zeromq
Signed-off-by: Dirk Chang <dirk@kooiot.com>
Diffstat (limited to 'lang/lpeg')
-rw-r--r--lang/lpeg/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/lang/lpeg/Makefile b/lang/lpeg/Makefile
new file mode 100644
index 000000000..ee8a4ef1f
--- /dev/null
+++ b/lang/lpeg/Makefile
@@ -0,0 +1,48 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lpeg
+PKG_VERSION:=0.12.2
+PKG_RELEASE:=1
+PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
+PKG_LICENSE:=MIT
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.inf.puc-rio.br/~roberto/lpeg/
+PKG_MD5SUM:=fabb614eb46e370d4f6b8fd82d17ca7e
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/lpeg
+ SUBMENU:=Lua
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=LPeg
+ URL:=http://www.inf.puc-rio.br/~roberto/lpeg/
+ DEPENDS:=+lua
+endef
+
+define Package/lpeg/description
+ LPeg is a new pattern-matching library for Lua, based on Parsing Expression Grammars (PEGs)
+endef
+
+define Build/Configure
+endef
+
+# add make variable overrides here
+MAKE_FLAGS +=
+
+define Package/lpeg/install
+ $(INSTALL_DIR) $(1)/usr/lib/lua
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/lpeg.so $(1)/usr/lib/lua
+endef
+
+$(eval $(call BuildPackage,lpeg))