aboutsummaryrefslogtreecommitdiff
path: root/lang/lpeg/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-06-05 17:44:27 -0700
committerFlorian Fainelli <f.fainelli@gmail.com>2017-06-05 17:44:27 -0700
commit140b3f2fe09ed12a6561697982189cf934fcbfd8 (patch)
tree7115e25cd2be5133c1d02b070210e44a63475780 /lang/lpeg/Makefile
parent3ffd13fbd2c16c1b297811702f6657ea10b62043 (diff)
lpeg: Fix build with external toolchains
We are not properly passing down TARGET_CFLAGS and TARGET_CPPFLAGS and this can be noticed with external toolchains with the following build error: mipsel-linux-gnu-gcc -Wall -Wextra -pedantic -Waggregate-return -Wcast-align -Wcast-qual -Wdisabled-optimization -Wpointer-arith -Wshadow -Wsign-compare -Wundef -Wwrite-strings -Wbad-function-cast -Wdeclaration-after-statement -Wmissing-prototypes -Wnested-externs -Wstrict-prototypes -O2 -std=c99 -I../lua/ -fPIC -c -o lpvm.o lpvm.c lpvm.c:10:17: fatal error: lua.h: No such file or directory #include "lua.h" ^ compilation terminated. make[4]: *** [lpvm.o] Error 1 Re-use COPT to pass our TARGET_CFLAGS and TARGET_CPPFLAGS Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'lang/lpeg/Makefile')
-rw-r--r--lang/lpeg/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/lang/lpeg/Makefile b/lang/lpeg/Makefile
index ee8a4ef1f..35f5aa673 100644
--- a/lang/lpeg/Makefile
+++ b/lang/lpeg/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=lpeg
PKG_VERSION:=0.12.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
PKG_LICENSE:=MIT
@@ -38,7 +38,8 @@ define Build/Configure
endef
# add make variable overrides here
-MAKE_FLAGS +=
+MAKE_FLAGS += \
+ COPT="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -O2"
define Package/lpeg/install
$(INSTALL_DIR) $(1)/usr/lib/lua