aboutsummaryrefslogtreecommitdiff
path: root/lang/golang
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-09-11 03:57:45 +0800
committerJeffery To <jeffery.to@gmail.com>2023-09-11 03:57:45 +0800
commitd9a999521ea3113f3c48b65d468917bf94f83821 (patch)
tree6c7d14ba8b8d148febffcb2f97f5b7cc43c016b1 /lang/golang
parentb2fc84a21b6f5c6129fb462a854add3a025a8165 (diff)
golang: Update to 1.21.1
Includes fixes for: * CVE-2023-39318: html/template: improper handling of HTML-like comments within script contexts * CVE-2023-39319: html/template: improper handling of special tags within script contexts * CVE-2023-39320: cmd/go: go.mod toolchain directive allows arbitrary execution * CVE-2023-39321 and CVE-2023-39322: crypto/tls: panic when processing partial post-handshake message in QUICConn.HandleData Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/golang')
-rw-r--r--lang/golang/golang/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/golang/golang/Makefile b/lang/golang/golang/Makefile
index 1022a6456..e91f34654 100644
--- a/lang/golang/golang/Makefile
+++ b/lang/golang/golang/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
GO_VERSION_MAJOR_MINOR:=1.21
-GO_VERSION_PATCH:=0
+GO_VERSION_PATCH:=1
PKG_NAME:=golang
PKG_VERSION:=$(GO_VERSION_MAJOR_MINOR)$(if $(GO_VERSION_PATCH),.$(GO_VERSION_PATCH))
@@ -20,7 +20,7 @@ GO_SOURCE_URLS:=https://dl.google.com/go/ \
PKG_SOURCE:=go$(PKG_VERSION).src.tar.gz
PKG_SOURCE_URL:=$(GO_SOURCE_URLS)
-PKG_HASH:=818d46ede85682dd551ad378ef37a4d247006f12ec59b5b755601d2ce114369a
+PKG_HASH:=bfa36bf75e9a1e9cbbdb9abcf9d1707e479bd3a07880a8ae3564caee5711cb99
PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
PKG_LICENSE:=BSD-3-Clause