aboutsummaryrefslogtreecommitdiff
path: root/lang/golang
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-09-02 16:11:45 +0800
committerJeffery To <jeffery.to@gmail.com>2020-10-05 00:25:28 +0800
commit4674564e42e0b30f477af6fd7dbb3a92c1656998 (patch)
tree62e9da458229d75fde4f813e2b4cede01f77b4cb /lang/golang
parentfc7cf379e381997f0c31e69f808911d756d613e3 (diff)
golang: Move config option into separate file
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/golang')
-rw-r--r--lang/golang/golang/Config.in15
-rw-r--r--lang/golang/golang/Makefile15
2 files changed, 16 insertions, 14 deletions
diff --git a/lang/golang/golang/Config.in b/lang/golang/golang/Config.in
new file mode 100644
index 000000000..6bbbf728c
--- /dev/null
+++ b/lang/golang/golang/Config.in
@@ -0,0 +1,15 @@
+menu "Configuration"
+
+config GOLANG_EXTERNAL_BOOTSTRAP_ROOT
+ string "External bootstrap Go root directory"
+ default ""
+ help
+ Path to a working Go tree (>= Go 1.4), with bin, pkg, and src
+ subdirectories and the Go compiler at bin/go.
+
+ If specified, the existing Go installation will be used to
+ compile host (buildroot) Go.
+
+ Leave blank to compile the default bootstrap Go.
+
+endmenu
diff --git a/lang/golang/golang/Makefile b/lang/golang/golang/Makefile
index 45d79bc32..c08028d09 100644
--- a/lang/golang/golang/Makefile
+++ b/lang/golang/golang/Makefile
@@ -155,20 +155,7 @@ libraries for the Go programming language.
endef
define Package/golang/config
-menu "Configuration"
-
-config GOLANG_EXTERNAL_BOOTSTRAP_ROOT
- string "External bootstrap Go root directory"
- help
- Path to a working Go tree (>= Go 1.4), with bin, pkg, and src
- subdirectories and the Go compiler at bin/go.
-
- If specified, the existing Go installation will be used to
- compile host (buildroot) Go.
-
- Leave blank to compile the default bootstrap Go.
-
-endmenu
+ source "$(SOURCE)/Config.in"
endef
define Package/golang-doc