aboutsummaryrefslogtreecommitdiff
path: root/lang/golang
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2018-11-06 19:23:57 +0800
committerJeffery To <jeffery.to@gmail.com>2018-11-06 19:32:23 +0800
commit275e6c4a3db0788ce25b315e457ff926ba8a2a8e (patch)
tree8470ce0d69d3f33159297e55ddb4d7db00a19c2a /lang/golang
parent9753c21d5c73a2a53a866fd8ee706acdddf90d6d (diff)
golang: Update to 1.11.2, fix build errors
When installing a newer host Go, be sure to remove the old host Go. Not doing so causes errors[1] when trying to build target Go. [1]: https://github.com/openwrt/packages/pull/7194#issuecomment-435948361 Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/golang')
-rw-r--r--lang/golang/golang-version.mk2
-rw-r--r--lang/golang/golang/Makefile4
2 files changed, 4 insertions, 2 deletions
diff --git a/lang/golang/golang-version.mk b/lang/golang/golang-version.mk
index 8fdafd03a..9e69d3bc8 100644
--- a/lang/golang/golang-version.mk
+++ b/lang/golang/golang-version.mk
@@ -11,4 +11,4 @@ endif
GO_VERSION_MAJOR_MINOR:=1.11
-GO_VERSION_PATCH:=1
+GO_VERSION_PATCH:=2
diff --git a/lang/golang/golang/Makefile b/lang/golang/golang/Makefile
index c9a27fda0..7b72a7a88 100644
--- a/lang/golang/golang/Makefile
+++ b/lang/golang/golang/Makefile
@@ -18,7 +18,7 @@ GO_SOURCE_URLS:=https://dl.google.com/go/ \
PKG_SOURCE:=go$(PKG_VERSION).src.tar.gz
PKG_SOURCE_URL:=$(GO_SOURCE_URLS)
-PKG_HASH:=558f8c169ae215e25b81421596e8de7572bd3ba824b79add22fba6e284db1117
+PKG_HASH:=042fba357210816160341f1002440550e952eb12678f7c9e7e9d389437942550
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE
@@ -180,6 +180,8 @@ endef
# when go compiles a program, it will use the host std lib
# so remove it now and force go to rebuild std for target later
define Host/Install
+ $(call Host/Uninstall)
+
$(call GoCompiler/Host/Install/Bin,)
$(call GoCompiler/Host/Install/Src,)