aboutsummaryrefslogtreecommitdiff
path: root/lang/django
diff options
context:
space:
mode:
authorGergely Kiss <mail.gery@gmail.com>2016-04-30 10:37:30 +0200
committerEtienne CHAMPETIER <champetier.etienne@gmail.com>2016-08-24 20:35:33 +0000
commit437621931a1561ae23604c619fde40f78d750c3c (patch)
tree59c792f612d9fb2f199d18e2397e3487248dbb1d /lang/django
parent39e937fae7608da2e260505e312d8d5f5ed7a225 (diff)
seafile: import version 5.1.1 and its dependencies
Signed-off-by: Gergely Kiss <mail.gery@gmail.com>
Diffstat (limited to 'lang/django')
-rw-r--r--lang/django/Makefile65
1 files changed, 65 insertions, 0 deletions
diff --git a/lang/django/Makefile b/lang/django/Makefile
new file mode 100644
index 000000000..c932cc1c4
--- /dev/null
+++ b/lang/django/Makefile
@@ -0,0 +1,65 @@
+#
+# Copyright (C) 2007-2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=django
+PKG_VERSION:=1.8.12
+PKG_RELEASE=1
+PKG_LICENSE:=BSD-3-Clause
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/django/django.git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=c168aeba175dbb92c615460a360cb1ea978de5d3
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+PKG_BUILD_DEPENDS:=python python-setuptools
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python-package.mk)
+
+define Package/django
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=The web framework for perfectionists with deadlines.
+ MAINTAINER:=Gergely Kiss <mail.gery@gmail.com>
+ URL:=https://www.djangoproject.com/
+ DEPENDS:=+python
+endef
+
+define Package/django/description
+ The web framework for perfectionists with deadlines.
+endef
+
+define Build/Compile
+ $(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(CP) \
+ $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
+ $(1)$(PYTHON_PKG_DIR)
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/django-admin.py \
+ $(1)/usr/bin
+endef
+
+define Package/django/install
+ $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(CP) \
+ $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
+ $(1)$(PYTHON_PKG_DIR)
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/django-admin.py \
+ $(1)/usr/bin
+ # fix python exec path
+ sed -i 's/#!.*/#!\/usr\/bin\/python/g' $(1)/usr/bin/django-admin.py
+endef
+
+$(eval $(call BuildPackage,django))