aboutsummaryrefslogtreecommitdiff
path: root/lang/cqueues/Makefile
diff options
context:
space:
mode:
authorSiger Yang <siger.yang@outlook.com>2022-01-15 21:18:08 +0800
committerRosen Penev <rosenp@gmail.com>2022-02-14 17:25:51 -0800
commit4137429a2586ce19f48466aaa3ea0d4b77d7e685 (patch)
tree7cafb8923b2bbeefebf31e73c34c3d8f79902eab /lang/cqueues/Makefile
parent34018f1fe03072266a55f3cabfe16fe6808838b0 (diff)
cqueues: add cqueues(rel-20200726) to feeds
Signed-off-by: Siger Yang <siger.yang@outlook.com>
Diffstat (limited to 'lang/cqueues/Makefile')
-rw-r--r--lang/cqueues/Makefile57
1 files changed, 57 insertions, 0 deletions
diff --git a/lang/cqueues/Makefile b/lang/cqueues/Makefile
new file mode 100644
index 000000000..0660665ac
--- /dev/null
+++ b/lang/cqueues/Makefile
@@ -0,0 +1,57 @@
+#
+# Copyright (C) 2022 Siger Yang <siger.yang@outlook.com>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=cqueues
+PKG_VERSION:=20200726
+PKG_RELEASE:=1
+PKG_MAINTAINER:=Siger Yang <siger.yang@outlook.com>
+
+PKG_MIRROR_HASH:=45bce9d3400f4c689d07ab3326610c2987424375dc575417eaafc6e5261b6009
+PKG_SOURCE_URL:=https://github.com/wahern/cqueues.git
+PKG_SOURCE_VERSION:=rel-$(PKG_VERSION)
+PKG_SOURCE_PROTO:=git
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/cqueues
+ SUBMENU:=Lua
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=lua cqueues
+ URL:=http://25thandclement.com/~william/projects/cqueues.html
+ DEPENDS:=+liblua +libopenssl
+endef
+
+define Package/cqueues/description
+ Continuation Queues: Embeddable asynchronous networking, threading, and
+ notification framework for Lua on Unix.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+TARGET_LDFLAGS += $(FPIC)
+
+MAKE_FLAGS += \
+ LUA_APIS="5.1" \
+ lua51cpath="/usr/lib/lua" \
+ lua51path="/usr/lib/lua"
+
+define Package/cqueues/install
+ $(INSTALL_DIR) $(1)/usr/lib/lua
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/lua/_cqueues.so $(1)/usr/lib/lua/
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/lua/cqueues.lua $(1)/usr/lib/lua/
+
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/lua/cqueues $(1)/usr/lib/lua/
+endef
+
+$(eval $(call BuildPackage,cqueues))