aboutsummaryrefslogtreecommitdiff
path: root/kernel/smbd
diff options
context:
space:
mode:
authorAndy Walsh <andy.walsh44+github@gmail.com>2019-12-31 14:59:11 +0100
committerAndy Walsh <andy.walsh44+github@gmail.com>2020-01-03 19:09:30 +0100
commit6c9973a9d9392489aa033c243842fdb29041f578 (patch)
treed9b7141363077daf1936bf7602910155db157d44 /kernel/smbd
parent7fb36fb8d017328f28520efb7932dd0df022fd75 (diff)
smbd: rename from cifsd, update to 3.0.1
* follow upstream rename to 'smbd' and 'smbd-tools' * config is '/config/smbd' and '/etc/smbd/smb.conf' * smbd: update to 3.0.1 * smbd: fixes delete access on readonly shares * smbd: add patch to keep version metadata in kmod * smbd: add synchrous kill_server patches * smbd-tools: update to 3.0.1 * smbd-tools: userspace service is now 'usmbd' * smbd-tools: userspace tools are: 'smbuseradd', 'smbshareadd' with /etc/smbd/smbdpwd.db * smbd-tools: split package into server/utils (reduce size) * smbd-tools: fix init (luci save&apply) * smbd-tools: remove kill_server related timeouts Signed-off-by: Andy Walsh <andy.walsh44+github@gmail.com>
Diffstat (limited to 'kernel/smbd')
-rw-r--r--kernel/smbd/Makefile52
-rw-r--r--kernel/smbd/patches/01-keep_kmod_metadata.patch10
2 files changed, 62 insertions, 0 deletions
diff --git a/kernel/smbd/Makefile b/kernel/smbd/Makefile
new file mode 100644
index 000000000..cb6da11af
--- /dev/null
+++ b/kernel/smbd/Makefile
@@ -0,0 +1,52 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=smbd
+PKG_VERSION:=3.0.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/cifsd-team/$(PKG_NAME)/archive/$(PKG_VERSION)/
+PKG_HASH:=6d1bf695aacd5a009eb30c10b31ff7c8942c8f201f7eb436b3cfa66f49d1f9f5
+
+PKG_MAINTAINER:=Andy Walsh <andy.walsh44+github@gmail.com>
+PKG_LICENSE:=GPL-2.0-or-later
+PKG_LICENSE_FILES:=COPYING
+
+include $(INCLUDE_DIR)/kernel.mk
+include $(INCLUDE_DIR)/package.mk
+
+define KernelPackage/fs-smbd
+ SUBMENU:=Filesystems
+ TITLE:=SMB kernel server support
+ URL:=https://github.com/cifsd-team/smbd
+ FILES:=$(PKG_BUILD_DIR)/smbd.ko
+ DEPENDS:= \
+ +kmod-nls-base \
+ +kmod-nls-utf8 \
+ +kmod-crypto-md4 \
+ +kmod-crypto-md5 \
+ +kmod-crypto-hmac \
+ +kmod-crypto-arc4 \
+ +kmod-crypto-ecb \
+ +kmod-crypto-des \
+ +kmod-crypto-sha256 \
+ +kmod-crypto-cmac \
+ +kmod-crypto-sha512 \
+ +kmod-crypto-aead \
+ +kmod-crypto-ccm \
+ +kmod-crypto-gcm
+endef
+
+define KernelPackage/fs-smbd/description
+ Smbd is an In-kernel SMB2/3 fileserver.
+ It's an implementation of the SMB protocol in kernel space for sharing files and IPC services over network.
+endef
+
+define Build/Compile
+ $(KERNEL_MAKE) SUBDIRS="$(PKG_BUILD_DIR)" \
+ EXTRA_CFLAGS="$(EXTRA_CFLAGS)" \
+ CONFIG_SMB_SERVER=m \
+ modules
+endef
+
+$(eval $(call KernelPackage,fs-smbd))
diff --git a/kernel/smbd/patches/01-keep_kmod_metadata.patch b/kernel/smbd/patches/01-keep_kmod_metadata.patch
new file mode 100644
index 000000000..9240852c8
--- /dev/null
+++ b/kernel/smbd/patches/01-keep_kmod_metadata.patch
@@ -0,0 +1,10 @@
+--- a/glob.h 2019-12-08
++++ b/glob.h 2019-12-08
+@@ -7,6 +7,8 @@
+ #ifndef __SMBD_GLOB_H
+ #define __SMBD_GLOB_H
+
++#undef CONFIG_MODULE_STRIPPED
++
+ #include <linux/ctype.h>
+ #include <linux/version.h>