aboutsummaryrefslogtreecommitdiff
path: root/kernel/pfring
diff options
context:
space:
mode:
authorBangLang Huang <banglang.huang@foxmail.com>2017-12-23 20:32:38 +0800
committerStijn Tintel <stijn@linux-ipv6.be>2018-10-02 20:43:48 +0300
commitbc01c8eae6ef0d87b1a0e6ac676605cacbd52014 (patch)
treee9537280d1efcd3b64265a9164d25ed53f946e08 /kernel/pfring
parentc4ab18d58e63130c7a88f881a8ba96628b9f8598 (diff)
libpfring: add new package
PF_RING is a high speed packet capture library that turns a commodity PC into an efficient and cheap network measurement box suitable for both packet and active traffic analysis and manipulation. Moreover, PF_RING opens totally new markets as it enables the creation of efficient application such as traffic balancers or packet filters in a matter of lines of codes. github : https://github.com/ntop/pf_ring official : https://www.ntop.org Signed-off-by: BangLang Huang <banglang.huang@foxmail.com> Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> [rename kmod-pfring to kmod-pf-ring]
Diffstat (limited to 'kernel/pfring')
-rw-r--r--kernel/pfring/Makefile63
1 files changed, 63 insertions, 0 deletions
diff --git a/kernel/pfring/Makefile b/kernel/pfring/Makefile
new file mode 100644
index 000000000..f175475ed
--- /dev/null
+++ b/kernel/pfring/Makefile
@@ -0,0 +1,63 @@
+#
+# Copyright (C) 2017 Banglang Huang
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=pf-ring
+PKG_VERSION:=7.2.0
+PKG_RELEASE:=1
+PKG_MAINTAINER:=Banglang Huang <banglang.huang@foxmail.com>
+
+PKG_LICENSE:=GPL-2.0
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/ntop/PF_RING/tar.gz/$(PKG_VERSION)?
+PKG_HASH:=5d349ac37a6ece5966bf606a6f131d628b98d88654c2f502d3c4b8bbf6ef9796
+
+PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/PF_RING-$(PKG_VERSION)
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+CONFIGURE_PATH:=kernel
+MAKE_PATH:=kernel
+
+define KernelPackage/pf-ring
+ SUBMENU:=Network Support
+ TITLE:=PF_RING Kernel driver
+ FILES:=$(PKG_BUILD_DIR)/kernel/pf_ring.ko
+ AUTOLOAD:=$(call AutoLoad,90,pf_ring,1)
+endef
+
+define KernelPackage/pf-ring/description
+ Kernel module for libpf-ring package
+endef
+
+EXTRA_CFLAGS += \
+ -I$(PKG_BUILD_DIR)/kernel
+
+MAKE_OPTS := \
+ ARCH="$(LINUX_KARCH)" \
+ CROSS_COMPILE="$(TARGET_CROSS)" \
+ SUBDIRS="$(PKG_BUILD_DIR)/kernel" \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ EXTRA_CFLAGS="$(EXTRA_CFLAGS)"
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include/linux
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/linux/*.h $(1)/usr/include/linux
+endef
+
+define Build/Compile
+ +$(MAKE) -C "$(LINUX_DIR)" \
+ $(MAKE_OPTS) \
+ modules
+endef
+
+$(eval $(call KernelPackage,pf-ring))