aboutsummaryrefslogtreecommitdiff
path: root/kernel/cifsd/Makefile
diff options
context:
space:
mode:
authorAndy Walsh <andy.walsh44+github@gmail.com>2019-12-31 14:59:11 +0100
committerAndy Walsh <andy.walsh44+github@gmail.com>2020-01-03 19:09:30 +0100
commit6c9973a9d9392489aa033c243842fdb29041f578 (patch)
treed9b7141363077daf1936bf7602910155db157d44 /kernel/cifsd/Makefile
parent7fb36fb8d017328f28520efb7932dd0df022fd75 (diff)
smbd: rename from cifsd, update to 3.0.1
* follow upstream rename to 'smbd' and 'smbd-tools' * config is '/config/smbd' and '/etc/smbd/smb.conf' * smbd: update to 3.0.1 * smbd: fixes delete access on readonly shares * smbd: add patch to keep version metadata in kmod * smbd: add synchrous kill_server patches * smbd-tools: update to 3.0.1 * smbd-tools: userspace service is now 'usmbd' * smbd-tools: userspace tools are: 'smbuseradd', 'smbshareadd' with /etc/smbd/smbdpwd.db * smbd-tools: split package into server/utils (reduce size) * smbd-tools: fix init (luci save&apply) * smbd-tools: remove kill_server related timeouts Signed-off-by: Andy Walsh <andy.walsh44+github@gmail.com>
Diffstat (limited to 'kernel/cifsd/Makefile')
-rw-r--r--kernel/cifsd/Makefile53
1 files changed, 0 insertions, 53 deletions
diff --git a/kernel/cifsd/Makefile b/kernel/cifsd/Makefile
deleted file mode 100644
index 890a5eb4c..000000000
--- a/kernel/cifsd/Makefile
+++ /dev/null
@@ -1,53 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=cifsd
-PKG_RELEASE:=1
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://github.com/cifsd-team/cifsd.git
-PKG_SOURCE_DATE:=2019-11-27
-PKG_SOURCE_VERSION:=b8675c8ac144ece00f3e6bcc5436c8ace99e23e9
-PKG_MIRROR_HASH:=3d67af87f30d837f95510663efc42f1451651dc235987408924b56cb277fc8e8
-
-PKG_MAINTAINER:=Andy Walsh <andy.walsh44+github@gmail.com>
-PKG_LICENSE:=GPL-2.0-or-later
-PKG_LICENSE_FILES:=COPYING
-
-include $(INCLUDE_DIR)/kernel.mk
-include $(INCLUDE_DIR)/package.mk
-
-define KernelPackage/fs-cifsd
- SUBMENU:=Filesystems
- TITLE:=CIFS/SMB kernel server support
- URL:=https://github.com/cifsd-team/cifsd
- FILES:=$(PKG_BUILD_DIR)/cifsd.ko
- DEPENDS:= \
- +kmod-nls-base \
- +kmod-nls-utf8 \
- +kmod-crypto-md4 \
- +kmod-crypto-md5 \
- +kmod-crypto-hmac \
- +kmod-crypto-ecb \
- +kmod-crypto-des \
- +kmod-crypto-sha256 \
- +kmod-crypto-cmac \
- +kmod-crypto-sha512 \
- +kmod-crypto-aead \
- +kmod-crypto-ccm
-endef
-
-define KernelPackage/fs-cifsd/description
- Kernel module for a CIFS/SMBv2,3 fileserver.
-endef
-
-# broken atm (needs CONFIG_KEYS=y)
-#EXTRA_CFLAGS+=-DCONFIG_CIFSD_ACL
-
-define Build/Compile
- $(KERNEL_MAKE) SUBDIRS="$(PKG_BUILD_DIR)" \
- EXTRA_CFLAGS="$(EXTRA_CFLAGS)" \
- CONFIG_CIFS_SERVER=m \
- modules
-endef
-
-$(eval $(call KernelPackage,fs-cifsd))