aboutsummaryrefslogtreecommitdiff
path: root/ipv6
diff options
context:
space:
mode:
authorOndřej Caletka <ondrej@caletka.cz>2014-11-30 18:57:28 +0100
committerOndřej Caletka <ondrej@caletka.cz>2014-12-01 15:15:35 +0100
commit6f704629524bc32f263b8440d80bbd1b13e3da71 (patch)
treeba896fc17661b96fb69032f8e6c28a87ba875080 /ipv6
parent7c9b5198cdcce3a79d389451206326eacdfc7f03 (diff)
aiccu: Add NTP hotplug hook
This hook simply writes current stratum to /var/run/aiccu_ntp_stratum, from where it is read by aiccu proto script. Signed-off-by: Ondrej Caletka <Ondrej@Caletka.cz>
Diffstat (limited to 'ipv6')
-rw-r--r--ipv6/aiccu/Makefile5
-rw-r--r--ipv6/aiccu/files/aiccu.hotplug3
2 files changed, 6 insertions, 2 deletions
diff --git a/ipv6/aiccu/Makefile b/ipv6/aiccu/Makefile
index bfa8a8320..50839f359 100644
--- a/ipv6/aiccu/Makefile
+++ b/ipv6/aiccu/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=aiccu
PKG_VERSION:=20070115
-PKG_RELEASE:=11
+PKG_RELEASE:=12
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
@@ -47,9 +47,10 @@ define Package/aiccu/conffiles
endef
define Package/aiccu/install
- $(INSTALL_DIR) $(1)/usr/sbin $(1)/lib/netifd/proto
+ $(INSTALL_DIR) $(1)/usr/sbin $(1)/lib/netifd/proto $(1)/etc/hotplug.d/ntp
$(INSTALL_BIN) $(PKG_BUILD_DIR)/unix-console/$(PKG_NAME) $(1)/usr/sbin/
$(INSTALL_BIN) ./files/aiccu.sh $(1)/lib/netifd/proto/aiccu.sh
+ $(INSTALL_DATA) ./files/aiccu.hotplug $(1)/etc/hotplug.d/ntp/10-aiccu
endef
$(eval $(call BuildPackage,aiccu))
diff --git a/ipv6/aiccu/files/aiccu.hotplug b/ipv6/aiccu/files/aiccu.hotplug
new file mode 100644
index 000000000..b52137170
--- /dev/null
+++ b/ipv6/aiccu/files/aiccu.hotplug
@@ -0,0 +1,3 @@
+#!/bin/sh
+NTPSTRATUMFILE="/var/run/aiccu_ntp_stratum"
+echo $stratum > "$NTPSTRATUMFILE"