aboutsummaryrefslogtreecommitdiff
path: root/ipv6
diff options
context:
space:
mode:
authorNikita Vostokov <yawosk@yandex.com>2020-03-22 15:48:28 +0300
committerNikita Vostokov <yawosk@yandex.com>2020-03-22 15:48:28 +0300
commit5db9091a1707a06391b213e42da9e7aca85a1913 (patch)
treea64eb88a492318e1f3e4d3c80fe07282c831c02c /ipv6
parent7a1e337f3915a0ebad296f6e0f231813bbbbee4e (diff)
miredo: Makefile fixes
* Move CONFIGURE blocks after description * Fix build with libcap Signed-off-by: Nikita Vostokov <yawosk@yandex.com>
Diffstat (limited to 'ipv6')
-rw-r--r--ipv6/miredo/Makefile32
1 files changed, 18 insertions, 14 deletions
diff --git a/ipv6/miredo/Makefile b/ipv6/miredo/Makefile
index b632540fe..e3498a891 100644
--- a/ipv6/miredo/Makefile
+++ b/ipv6/miredo/Makefile
@@ -21,20 +21,6 @@ PKG_LICENSE_FILES:=COPYING
include $(INCLUDE_DIR)/package.mk
-CONFIGURE_ARGS+= \
- --enable-shared \
- --enable-static \
- --disable-binreloc \
- --with-pic \
- --without-libiconv-prefix \
- --without-libintl-prefix
-
-TARGET_CFLAGS+= $(FPIC) \
- -ffunction-sections \
- -fdata-sections
-
-TARGET_LDFLAGS += -Wl,--gc-sections
-
define Package/miredo
SECTION:=net
CATEGORY:=Network
@@ -50,6 +36,24 @@ define Package/miredo/description
IPv6 connectivity even from behind NAT devices.
endef
+CONFIGURE_ARGS+= \
+ --enable-shared \
+ --enable-static \
+ --disable-binreloc \
+ --with-pic \
+ --without-libiconv-prefix \
+ --without-libintl-prefix
+
+CONFIGURE_VARS += \
+ ac_cv_header_sys_capability_h=no
+
+TARGET_CFLAGS+= \
+ $(FPIC) \
+ -ffunction-sections \
+ -fdata-sections
+
+TARGET_LDFLAGS += -Wl,--gc-sections
+
define Package/miredo/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/