aboutsummaryrefslogtreecommitdiff
path: root/ipv6
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-02-02 21:58:48 -0800
committerRosen Penev <rosenp@gmail.com>2021-02-02 22:39:56 -0800
commit081da5a22871744738499f588f076fcb542d4004 (patch)
tree8fee87dd8859dc0545e3db7a6564c76b2f762700 /ipv6
parent04c911aeb069cfb9d70e55d57d2695501828e251 (diff)
miredo: add debian reproducibility patch
Refreshed other patches. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'ipv6')
-rw-r--r--ipv6/miredo/Makefile2
-rw-r--r--ipv6/miredo/patches/001-fix-musl-pthread-non-portable.patch8
-rw-r--r--ipv6/miredo/patches/002-fix-redefinition-ethadr.patch7
-rw-r--r--ipv6/miredo/patches/003-fix-warnings-portable-defined.patch14
-rw-r--r--ipv6/miredo/patches/004-reproducible.patch26
5 files changed, 41 insertions, 16 deletions
diff --git a/ipv6/miredo/Makefile b/ipv6/miredo/Makefile
index e3498a891..f25a86df4 100644
--- a/ipv6/miredo/Makefile
+++ b/ipv6/miredo/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=miredo
PKG_VERSION:=1.2.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=miredo-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.remlab.net/files/miredo/
diff --git a/ipv6/miredo/patches/001-fix-musl-pthread-non-portable.patch b/ipv6/miredo/patches/001-fix-musl-pthread-non-portable.patch
index bbaa54c4d..4eb19b037 100644
--- a/ipv6/miredo/patches/001-fix-musl-pthread-non-portable.patch
+++ b/ipv6/miredo/patches/001-fix-musl-pthread-non-portable.patch
@@ -1,6 +1,6 @@
---- a/libteredo/debug.h 2009-02-28 23:17:14.000000000 +0300
-+++ b/libteredo/debug.h 2019-04-07 01:46:48.235087395 +0300
-@@ -43,8 +43,10 @@
+--- a/libteredo/debug.h
++++ b/libteredo/debug.h
+@@ -43,8 +43,10 @@ static inline void debug (const char *st
# ifdef __linux__
# include <errno.h>
# include <assert.h>
@@ -13,7 +13,7 @@
static inline int
d_pthread_mutex_init (pthread_mutex_t *mutex, pthread_mutexattr_t *pattr)
-@@ -57,7 +59,7 @@
+@@ -57,7 +59,7 @@ d_pthread_mutex_init (pthread_mutex_t *m
pthread_mutexattr_init (&attr);
}
diff --git a/ipv6/miredo/patches/002-fix-redefinition-ethadr.patch b/ipv6/miredo/patches/002-fix-redefinition-ethadr.patch
index 5cd20f4a5..ead27096d 100644
--- a/ipv6/miredo/patches/002-fix-redefinition-ethadr.patch
+++ b/ipv6/miredo/patches/002-fix-redefinition-ethadr.patch
@@ -1,5 +1,5 @@
---- a/libtun6/tun6.c 2012-09-12 17:03:59.000000000 +0400
-+++ b/libtun6/tun6.c 2019-04-07 02:21:07.439952535 +0300
+--- a/libtun6/tun6.c
++++ b/libtun6/tun6.c
@@ -53,7 +53,7 @@
const char os_driver[] = "Linux";
# define USE_LINUX 1
@@ -9,7 +9,7 @@
/*
* <linux/ipv6.h> conflicts with <netinet/in.h> and <arpa/inet.h>,
* so we've got to declare this structure by hand.
-@@ -65,7 +65,7 @@
+@@ -65,7 +65,7 @@ struct in6_ifreq {
};
# include <net/route.h> // struct in6_rtmsg
@@ -18,4 +18,3 @@
typedef struct
{
-
diff --git a/ipv6/miredo/patches/003-fix-warnings-portable-defined.patch b/ipv6/miredo/patches/003-fix-warnings-portable-defined.patch
index d812f7776..a74d77b8f 100644
--- a/ipv6/miredo/patches/003-fix-warnings-portable-defined.patch
+++ b/ipv6/miredo/patches/003-fix-warnings-portable-defined.patch
@@ -1,6 +1,6 @@
---- a/include/gettext.h 2012-09-12 16:57:52.000000000 +0400
-+++ b/include/gettext.h 2019-04-07 01:11:52.492519796 +0300
-@@ -182,7 +182,7 @@
+--- a/include/gettext.h
++++ b/include/gettext.h
+@@ -182,7 +182,7 @@ npgettext_aux (const char *domain,
(((__GNUC__ >= 3 || __GNUG__ >= 2) && !defined(__STRICT_ANSI__)) \
/* || __STDC_VERSION__ >= 199901L */ )
@@ -9,7 +9,7 @@
#include <stdlib.h>
#endif
-@@ -206,7 +206,7 @@
+@@ -206,7 +206,7 @@ dcpgettext_expr (const char *domain,
size_t msgctxt_len = strlen (msgctxt) + 1;
size_t msgid_len = strlen (msgid) + 1;
const char *translation;
@@ -18,7 +18,7 @@
char msg_ctxt_id[msgctxt_len + msgid_len];
#else
char buf[1024];
-@@ -221,7 +221,7 @@
+@@ -221,7 +221,7 @@ dcpgettext_expr (const char *domain,
msg_ctxt_id[msgctxt_len - 1] = '\004';
memcpy (msg_ctxt_id + msgctxt_len, msgid, msgid_len);
translation = dcgettext (domain, msg_ctxt_id, category);
@@ -27,7 +27,7 @@
if (msg_ctxt_id != buf)
free (msg_ctxt_id);
#endif
-@@ -252,7 +252,7 @@
+@@ -252,7 +252,7 @@ dcnpgettext_expr (const char *domain,
size_t msgctxt_len = strlen (msgctxt) + 1;
size_t msgid_len = strlen (msgid) + 1;
const char *translation;
@@ -36,7 +36,7 @@
char msg_ctxt_id[msgctxt_len + msgid_len];
#else
char buf[1024];
-@@ -267,7 +267,7 @@
+@@ -267,7 +267,7 @@ dcnpgettext_expr (const char *domain,
msg_ctxt_id[msgctxt_len - 1] = '\004';
memcpy (msg_ctxt_id + msgctxt_len, msgid, msgid_len);
translation = dcngettext (domain, msg_ctxt_id, msgid_plural, n, category);
diff --git a/ipv6/miredo/patches/004-reproducible.patch b/ipv6/miredo/patches/004-reproducible.patch
new file mode 100644
index 000000000..62bae2a3f
--- /dev/null
+++ b/ipv6/miredo/patches/004-reproducible.patch
@@ -0,0 +1,26 @@
+From: Tomasz Buchert <tomasz@debian.org>
+Date: Fri, 6 Feb 2015 11:33:20 +0100
+Subject: Fix reproducibility issues
+
+We replace unreproducible CC macros with
+N/A placeholders. This fixes #776716.
+---
+ src/main.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+--- a/src/main.c
++++ b/src/main.c
+@@ -92,10 +92,11 @@ miredo_version (void)
+ #ifndef VERSION
+ # define VERSION "unknown version"
+ #endif
++ const char* UNKNOWN = "N/A";
+ printf (_("Miredo: Teredo IPv6 tunneling software %s (%s)\n"
+ " built %s on %s (%s)\n"),
+- VERSION, PACKAGE_HOST, __DATE__,
+- PACKAGE_BUILD_HOSTNAME, PACKAGE_BUILD);
++ VERSION, UNKNOWN, UNKNOWN,
++ UNKNOWN, UNKNOWN);
+ printf (_("Configured with: %s\n"), PACKAGE_CONFIGURE_INVOCATION);
+ puts (_("Written by Remi Denis-Courmont.\n"));
+