aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2021-05-28 20:53:45 +0800
committerRosen Penev <rosenp@gmail.com>2021-10-20 13:05:28 -0700
commitf63905280078030e122757fa3cf1a0933acf2cc2 (patch)
treecd217783cf0cc05fe57895ab8a8f7291c5d8cd47 /devel
parentc65e320961ab381ceedda01112db08bac60eb299 (diff)
statik: add new packages
This is required by cloudreve. Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/statik/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/devel/statik/Makefile b/devel/statik/Makefile
new file mode 100644
index 000000000..cd8f5c697
--- /dev/null
+++ b/devel/statik/Makefile
@@ -0,0 +1,49 @@
+# SPDX-License-Identifier: GPL-3.0-only
+#
+# Copyright (C) 2021 ImmortalWrt.org
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=statik
+PKG_VERSION:=0.1.7
+PKG_RELEASE:=$(AUTORELEASE)
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/rakyll/statik/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=cd05f409e63674f29cff0e496bd33eee70229985243cce486107085fab747082
+
+PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Tianling Shen <cnsztl@immortalwrt.org>
+
+HOST_BUILD_DEPENDS:=golang/host
+HOST_BUILD_PARALLEL:=1
+
+PKG_BUILD_DEPENDS:=golang/host
+PKG_BUILD_PARALLEL:=1
+PKG_USE_MIPS16:=0
+
+GO_PKG:=github.com/rakyll/statik
+
+include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/package.mk
+include ../../lang/golang/golang-host-build.mk
+include ../../lang/golang/golang-package.mk
+
+define Package/statik
+ SECTION:=devel
+ CATEGORY:=Development
+ TITLE:=Embed files into a Go executable
+ URL:=https://github.com/rakyll/statik
+ DEPENDS:=$(GO_ARCH_DEPENDS)
+endef
+
+define Package/statik/description
+ statik allows you to embed a directory of static files into your Go
+ binary to be later served from an http.FileSystem.
+endef
+
+$(eval $(call GoBinHostBuild))
+$(eval $(call HostBuild))
+$(eval $(call GoBinPackage,statik))
+$(eval $(call BuildPackage,statik))