aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2022-08-25 15:49:13 -0400
committerRosen Penev <rosenp@gmail.com>2022-09-09 15:20:58 -0700
commitac45a7455120e870af597eb020ef2dc8c84873a7 (patch)
treef1368e053cd2555498f857cc7bea234d3317fe74 /devel
parent1c49d1a309bf360942d07b39cd1794e32e5c3da2 (diff)
flex: install dev files to staging
Provide the library and headers for flex in the staging directory for the target build of packages that depend on lexical functions. Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'devel')
-rw-r--r--devel/flex/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/devel/flex/Makefile b/devel/flex/Makefile
index 5f2c12e0c..3b7d1ce1c 100644
--- a/devel/flex/Makefile
+++ b/devel/flex/Makefile
@@ -36,6 +36,12 @@ endef
CONFIGURE_ARGS += --disable-shared --disable-bootstrap
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
+endef
+
define Package/flex/install
$(INSTALL_DIR) $(1)/usr/bin/
$(CP) \