aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorkrant <aleksey.vasilenko@gmail.com>2024-02-06 15:14:18 +0200
committerRosen Penev <rosenp@gmail.com>2024-02-07 13:56:41 -0800
commit8e1c7880595054075b4f5b2afd4dd8da5f97691c (patch)
tree8da7fa0104a8ca7668bd94bd01d9bbce5a08db0b /devel
parent2ce8d58722013a95a1551779c299663d6dc709d5 (diff)
diffutils: update to 3.10
- Switch package URL to HTTPS - Refresh the patch Signed-off-by: krant <aleksey.vasilenko@gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/diffutils/Makefile6
-rw-r--r--devel/diffutils/patches/010-ppc.patch22
2 files changed, 14 insertions, 14 deletions
diff --git a/devel/diffutils/Makefile b/devel/diffutils/Makefile
index f3dc14c94..dfd5e0f78 100644
--- a/devel/diffutils/Makefile
+++ b/devel/diffutils/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=diffutils
-PKG_VERSION:=3.8
+PKG_VERSION:=3.10
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/diffutils
-PKG_HASH:=a6bdd7d1b31266d11c4f4de6c1b748d4607ab0231af5188fc2533d0ae2438fec
+PKG_HASH:=90e5e93cc724e4ebe12ede80df1634063c7a855692685919bfe60b556c9bd09e
PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
PKG_LICENSE:=GPL-3.0
@@ -30,7 +30,7 @@ define Package/diffutils
CATEGORY:=Development
DEPENDS:=+USE_GLIBC:librt
TITLE:=diffutils
- URL:=http://www.gnu.org/software/diffutils/
+ URL:=https://www.gnu.org/software/diffutils/
ALTERNATIVES:=\
200:/usr/bin/cmp:/usr/libexec/cmp-gnu \
200:/usr/bin/diff:/usr/libexec/diff-gnu
diff --git a/devel/diffutils/patches/010-ppc.patch b/devel/diffutils/patches/010-ppc.patch
index 530b79fea..f2b55a58e 100644
--- a/devel/diffutils/patches/010-ppc.patch
+++ b/devel/diffutils/patches/010-ppc.patch
@@ -1,13 +1,13 @@
--- a/lib/sigsegv.c
+++ b/lib/sigsegv.c
-@@ -219,8 +219,8 @@ int libsigsegv_version = LIBSIGSEGV_VERS
- # define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.gp_regs[1]
- # else /* 32-bit */
- /* both should be equivalent */
--# if 0
--# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.regs->gpr[1]
-+# ifndef __GLIBC__
-+# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.gregs[1]
- # else
- # define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.uc_regs->gregs[1]
- # endif
+@@ -244,8 +244,8 @@ int libsigsegv_version = LIBSIGSEGV_VERS
+ /* Assume the structure of ucontext_t in
+ glibc/sysdeps/unix/sysv/linux/powerpc/sys/ucontext.h. */
+ /* Because of the union, both definitions should be equivalent. */
+-# if 0
+-# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.regs->gpr[1]
++# ifndef __GLIBC__
++# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.gregs[1]
+ # else
+ # define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.uc_regs->gregs[1]
+ # endif