aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2023-05-12 13:53:32 +0200
committerNick Hainke <vincent@systemli.org>2023-05-16 18:43:31 +0200
commit7a251bd3ff3d775d231bec390b8002f0c48096a6 (patch)
tree36ff87fdc974287f561ad11bf8b2ce71d1c329eb /devel
parent54cc4cc7f6e90fd16139d3e4f98f6fe9b577f2f6 (diff)
gcc: update to 12.3.0
Release notes: https://gcc.gnu.org/gcc-12/changes.html Refresh patches: - 230-musl_libssp.patch - 910-mbsd_multi.patch - 920-specs_nonfatal_getenv.patch - 970-macos_arm64-building-fix.patch Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/gcc/Makefile4
-rw-r--r--devel/gcc/patches/12.3.0/230-musl_libssp.patch2
-rw-r--r--devel/gcc/patches/12.3.0/910-mbsd_multi.patch2
-rw-r--r--devel/gcc/patches/12.3.0/920-specs_nonfatal_getenv.patch2
-rw-r--r--devel/gcc/patches/12.3.0/970-macos_arm64-building-fix.patch2
5 files changed, 6 insertions, 6 deletions
diff --git a/devel/gcc/Makefile b/devel/gcc/Makefile
index 934de788b..e45372e4f 100644
--- a/devel/gcc/Makefile
+++ b/devel/gcc/Makefile
@@ -46,8 +46,8 @@ ifeq ($(PKG_VERSION),11.3.0)
PKG_HASH:=b47cf2818691f5b1e21df2bb38c795fac2cfbd640ede2d0a5e1c89e338a3ac39
endif
-ifeq ($(PKG_VERSION),12.2.0)
- PKG_HASH:=e549cf9cf3594a00e27b6589d4322d70e0720cdd213f39beb4181e06926230ff
+ifeq ($(PKG_VERSION),12.3.0)
+ PKG_HASH:=949a5d4f99e786421a93b532b22ffab5578de7321369975b91aec97adfda8c3b
endif
PATCH_DIR=./patches/$(GCC_VERSION)
diff --git a/devel/gcc/patches/12.3.0/230-musl_libssp.patch b/devel/gcc/patches/12.3.0/230-musl_libssp.patch
index 3ce5e4958..a909d6387 100644
--- a/devel/gcc/patches/12.3.0/230-musl_libssp.patch
+++ b/devel/gcc/patches/12.3.0/230-musl_libssp.patch
@@ -1,6 +1,6 @@
--- a/gcc/gcc.cc
+++ b/gcc/gcc.cc
-@@ -985,7 +985,9 @@ proper position among the other output f
+@@ -987,7 +987,9 @@ proper position among the other output f
#endif
#ifndef LINK_SSP_SPEC
diff --git a/devel/gcc/patches/12.3.0/910-mbsd_multi.patch b/devel/gcc/patches/12.3.0/910-mbsd_multi.patch
index 4033c5b23..0f75d0ce0 100644
--- a/devel/gcc/patches/12.3.0/910-mbsd_multi.patch
+++ b/devel/gcc/patches/12.3.0/910-mbsd_multi.patch
@@ -134,7 +134,7 @@ Date: Tue Jul 31 00:52:27 2007 +0000
@opindex Wno-stack-protector
--- a/gcc/opts.cc
+++ b/gcc/opts.cc
-@@ -2692,6 +2692,9 @@ common_handle_option (struct gcc_options
+@@ -2699,6 +2699,9 @@ common_handle_option (struct gcc_options
add_comma_separated_to_vector (&opts->x_flag_ignored_attributes, arg);
break;
diff --git a/devel/gcc/patches/12.3.0/920-specs_nonfatal_getenv.patch b/devel/gcc/patches/12.3.0/920-specs_nonfatal_getenv.patch
index 0f7d40b24..59bd35004 100644
--- a/devel/gcc/patches/12.3.0/920-specs_nonfatal_getenv.patch
+++ b/devel/gcc/patches/12.3.0/920-specs_nonfatal_getenv.patch
@@ -7,7 +7,7 @@ Date: Sat Apr 21 03:02:39 2012 +0000
--- a/gcc/gcc.cc
+++ b/gcc/gcc.cc
-@@ -10213,8 +10213,10 @@ getenv_spec_function (int argc, const ch
+@@ -10186,8 +10186,10 @@ getenv_spec_function (int argc, const ch
}
if (!value)
diff --git a/devel/gcc/patches/12.3.0/970-macos_arm64-building-fix.patch b/devel/gcc/patches/12.3.0/970-macos_arm64-building-fix.patch
index 86fa68e1b..89730449f 100644
--- a/devel/gcc/patches/12.3.0/970-macos_arm64-building-fix.patch
+++ b/devel/gcc/patches/12.3.0/970-macos_arm64-building-fix.patch
@@ -17,7 +17,7 @@ Date: Mon Aug 16 13:16:21 2021 +0100
--- a/gcc/config/aarch64/aarch64.h
+++ b/gcc/config/aarch64/aarch64.h
-@@ -1290,7 +1290,7 @@ extern const char *aarch64_rewrite_mcpu
+@@ -1293,7 +1293,7 @@ extern const char *aarch64_rewrite_mcpu
#define MCPU_TO_MARCH_SPEC_FUNCTIONS \
{ "rewrite_mcpu", aarch64_rewrite_mcpu },