aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorRen Zongjia <acooler15@foxmail.com>2021-09-12 17:31:21 +0800
committerRosen Penev <rosenp@gmail.com>2021-09-12 10:57:29 -0700
commit72f3dfcb0e1c2acb225d282c6968e42852df6cef (patch)
treed7d6f3dc8549372ab2c895ebf061d1ebdd1fb742 /devel
parent7534f5ba764f6c42888820eb14459694501da654 (diff)
autoconf: fix shebang
Fix shebang errors for autom4te, autoreconf, autoheader, autoscan, autoupdate, ifnames. resolve openwrt/packages#16604 Signed-off-by: Ren Zongjia <acooler15@foxmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/autoconf/Makefile5
-rw-r--r--devel/autoconf/test.sh8
2 files changed, 12 insertions, 1 deletions
diff --git a/devel/autoconf/Makefile b/devel/autoconf/Makefile
index c7a9d7577..8d6ff7d15 100644
--- a/devel/autoconf/Makefile
+++ b/devel/autoconf/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=autoconf
PKG_VERSION:=2.70
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=@GNU/autoconf
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -39,9 +39,12 @@ endef
CONFIGURE_VARS += M4=m4 EMACS=no
+FIX_PATHS = $(SED) '1c \#!/usr/bin/perl' -e 's| /[^ ]*/bin/perl| /usr/bin/perl|g'
+
define Package/autoconf/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+ grep -rEl "#\!.*perl" $(1)/usr/bin/ | xargs $(FIX_PATHS)
$(INSTALL_DIR) $(1)/usr/share/autoconf
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/autoconf/INSTALL \
$(1)/usr/share/autoconf/
diff --git a/devel/autoconf/test.sh b/devel/autoconf/test.sh
new file mode 100644
index 000000000..6a3b9505f
--- /dev/null
+++ b/devel/autoconf/test.sh
@@ -0,0 +1,8 @@
+#!/bin/sh
+autoconf --version | grep $2 && \
+autoheader --version | grep $2 && \
+autom4te --version | grep $2 && \
+autoreconf --version | grep $2 && \
+autoscan --version | grep $2 && \
+autoupdate --version | grep $2 && \
+ifnames --version | grep $2