aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorchamptar <champetier.etienne@gmail.com>2016-07-02 11:36:16 +0200
committerGitHub <noreply@github.com>2016-07-02 11:36:16 +0200
commit2bdc3323fe2ada09e16ebc3b712d7278f328be73 (patch)
tree942e67b1a81dddd748be97ef28c5d48e7957329d /devel
parent21c6feb8ce62ae90bb3b431e1b64300e0623c13c (diff)
parent93c32e1a88f3ecd28ca22214e1eefd458a3be69b (diff)
Merge pull request #2572 from Skeen/lpc21isp
lpc21isp: Add the package
Diffstat (limited to 'devel')
1 files changed, 42 insertions, 0 deletions
diff --git a/devel/lpc21isp/Makefile b/devel/lpc21isp/Makefile
new file mode 100644
index 000000000..292b7a439
--- /dev/null
+++ b/devel/lpc21isp/Makefile
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lpc21isp
+PKG_VERSION:=197
+PKG_RELEASE:=1
+PKG_LICENSE:=LGPL-3.0+
+PKG_LICENSE_FILES:=README gpl.txt lgpl-3.0.txt
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/lpc21isp_$(PKG_VERSION)
+PKG_SOURCE:=lpc21isp_$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/lpc21isp
+PKG_MD5SUM:=0b286859a05a725647ecb1b3fe9ba606
+PKG_CAT:=zcat
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/lpc21isp
+ SECTION:=base
+ CATEGORY:=Development
+ TITLE:=Command line ISP for NXP LPC family and ADUC70xx
+ URL:=http://lpc21isp.sourceforge.net/
+ MAINTAINER:=Emil 'Skeen' Madsen <sovende@gmail.com>
+endef
+
+define Package/lpc21isp/description
+ Portable command line ISP (In-circuit Programmer) for NXP LPC family
+ and Analog Devices ADUC70xx.
+endef
+
+define Package/lpc21isp/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/lpc21isp $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,lpc21isp))