aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2023-06-19 17:25:04 +0800
committerRosen Penev <rosenp@gmail.com>2023-06-22 21:38:36 +0300
commit27b4291bd474f1517fc1a00ee7b8e7e69ded8a55 (patch)
treea6c24a93a5eb156766f4544637193c6bc79119c8 /devel
parentb53a83815f7a496e60b1e4d4347b1bebf4913207 (diff)
gitlab-runner: Update to 16.0.2
* Added test.sh script * Fixed build with riscv64 * Passed package version via go ldflags * Refreshed patches * Removed useless test binaries from package Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/gitlab-runner/Makefile15
-rw-r--r--devel/gitlab-runner/patches/010-test.patch2
-rw-r--r--devel/gitlab-runner/test.sh3
3 files changed, 16 insertions, 4 deletions
diff --git a/devel/gitlab-runner/Makefile b/devel/gitlab-runner/Makefile
index 575db4707..801119e07 100644
--- a/devel/gitlab-runner/Makefile
+++ b/devel/gitlab-runner/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gitlab-runner
-PKG_VERSION:=14.3.2
-PKG_RELEASE:=2
+PKG_VERSION:=16.0.2
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v$(PKG_VERSION)
-PKG_HASH:=f67aeae05349f5c612ea5d8772407237caf4da586c0365e3c7edceec6b853d8c
+PKG_HASH:=f874b9babe21ae04007abfc901e9ad4c0c1ec22095d4de3e22e176914683cb5d
PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec1@gmail.com>
PKG_LICENSE:=MIT
@@ -23,7 +23,9 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/gitlab-runner-v$(PKG_VERSION)
PKG_BUILD_DEPENDS:=golang/host
PKG_BUILD_PARALLEL:=1
PKG_BUILD_FLAGS:=no-mips16
+
GO_PKG:=gitlab.com/gitlab-org/gitlab-runner
+GO_PKG_LDFLAGS_X:=$(GO_PKG)/common.VERSION=$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
include ../../lang/golang/golang-package.mk
@@ -41,5 +43,12 @@ define Package/gitlab-runner/description
GitLab CI/CD to run jobs in a pipeline.
endef
+define Package/gitlab-runner/install
+ $(call GoPackage/Package/Install/Bin,$(PKG_INSTALL_DIR))
+ $(INSTALL_DIR) $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gitlab-runner $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gitlab-runner-helper $(1)/usr/bin/
+endef
+
$(eval $(call GoBinPackage,gitlab-runner))
$(eval $(call BuildPackage,gitlab-runner))
diff --git a/devel/gitlab-runner/patches/010-test.patch b/devel/gitlab-runner/patches/010-test.patch
index 5bf5dfbe8..f66940508 100644
--- a/devel/gitlab-runner/patches/010-test.patch
+++ b/devel/gitlab-runner/patches/010-test.patch
@@ -1,6 +1,6 @@
--- a/common/buildtest/masking.go
+++ b/common/buildtest/masking.go
-@@ -45,7 +45,7 @@ func RunBuildWithMasking(t *testing.T, c
+@@ -55,7 +55,7 @@ func RunBuildWithMasking(t *testing.T, c
buf.Finish()
diff --git a/devel/gitlab-runner/test.sh b/devel/gitlab-runner/test.sh
new file mode 100644
index 000000000..151714709
--- /dev/null
+++ b/devel/gitlab-runner/test.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+gitlab-runner --version | grep "$PKG_VERSION"