diff options
author | Paul Fertser <fercerpav@gmail.com> | 2023-04-21 16:32:27 +0000 |
---|---|---|
committer | Paul Spooren <mail@aparcar.org> | 2023-04-21 22:46:58 +0200 |
commit | 0c10c224be81f9221dabfab449855ab6718d2a0c (patch) | |
tree | c7e9f983c60cbf9ae17bce5f64dc72963c67a6d3 /devel | |
parent | 018fcf3ccd3c65c92f7c9467ab35f345fbd2c1ae (diff) |
treewide: remove AUTORELEASE
Automatically compute and substitute current values for all
$(AUTORELEASE) instances as this feature is deprecated and shouldn't be
used.
The following temporary change was made to the core:
diff --git a/rules.mk b/rules.mk
index 57d7995d4fa8..f16367de87a8 100644
--- a/rules.mk
+++ b/rules.mk
@@ -429,7 +429,7 @@ endef
abi_version_str = $(subst -,,$(subst _,,$(subst .,,$(1))))
COMMITCOUNT = $(if $(DUMP),0,$(call commitcount))
-AUTORELEASE = $(if $(DUMP),0,$(call commitcount,1))
+AUTORELEASE = $(if $(DUMP),0,$(shell sed -i "s/\$$(AUTORELEASE)/$(call commitcount,1)/" $(CURDIR)/Makefile))
all:
FORCE: ;
And this command used to fix affected packages:
for i in $(cd feeds/packages; git grep -l PKG_RELEASE:=.*AUTORELEASE | \
sed 's^.*/\([^/]*\)/Makefile^\1^';);
do
make package/$i/download
done
Signed-off-by: Paul Fertser <fercerpav@gmail.com>
Diffstat (limited to 'devel')
-rw-r--r-- | devel/bison/Makefile | 2 | ||||
-rw-r--r-- | devel/diffutils/Makefile | 2 | ||||
-rw-r--r-- | devel/flex/Makefile | 2 | ||||
-rw-r--r-- | devel/gitlab-runner/Makefile | 2 | ||||
-rw-r--r-- | devel/m4/Makefile | 2 | ||||
-rw-r--r-- | devel/pkgconf/Makefile | 2 |
6 files changed, 6 insertions, 6 deletions
diff --git a/devel/bison/Makefile b/devel/bison/Makefile index 94183f9d9..09cd23309 100644 --- a/devel/bison/Makefile +++ b/devel/bison/Makefile @@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk PKG_NAME:=bison PKG_VERSION:=3.8.2 -PKG_RELEASE:=$(AUTORELEASE) +PKG_RELEASE:=1 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz PKG_SOURCE_URL:=@GNU/$(PKG_NAME) diff --git a/devel/diffutils/Makefile b/devel/diffutils/Makefile index a75a2b5d6..98333df2a 100644 --- a/devel/diffutils/Makefile +++ b/devel/diffutils/Makefile @@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk PKG_NAME:=diffutils PKG_VERSION:=3.8 -PKG_RELEASE:=$(AUTORELEASE) +PKG_RELEASE:=1 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz PKG_SOURCE_URL:=@GNU/diffutils diff --git a/devel/flex/Makefile b/devel/flex/Makefile index 3b7d1ce1c..a61d95358 100644 --- a/devel/flex/Makefile +++ b/devel/flex/Makefile @@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk PKG_NAME:=flex PKG_VERSION:=2.6.4 -PKG_RELEASE:=$(AUTORELEASE) +PKG_RELEASE:=4 PKG_CPE_ID:=cpe:/a:flex_project:flex PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz diff --git a/devel/gitlab-runner/Makefile b/devel/gitlab-runner/Makefile index 4e1ac59ac..575db4707 100644 --- a/devel/gitlab-runner/Makefile +++ b/devel/gitlab-runner/Makefile @@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk PKG_NAME:=gitlab-runner PKG_VERSION:=14.3.2 -PKG_RELEASE:=$(AUTORELEASE) +PKG_RELEASE:=2 PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz PKG_SOURCE_URL:=https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v$(PKG_VERSION) diff --git a/devel/m4/Makefile b/devel/m4/Makefile index b4937b1be..89635807b 100644 --- a/devel/m4/Makefile +++ b/devel/m4/Makefile @@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk PKG_NAME:=m4 PKG_VERSION:=1.4.19 -PKG_RELEASE:=$(AUTORELEASE) +PKG_RELEASE:=1 PKG_SOURCE_URL:=@GNU/m4 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz diff --git a/devel/pkgconf/Makefile b/devel/pkgconf/Makefile index c2a2415f4..171358d55 100644 --- a/devel/pkgconf/Makefile +++ b/devel/pkgconf/Makefile @@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk PKG_NAME:=pkgconf PKG_VERSION:=1.8.0 -PKG_RELEASE:=$(AUTORELEASE) +PKG_RELEASE:=2 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz PKG_SOURCE_URL:=https://distfiles.dereferenced.org/pkgconf |