aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-01-08 20:25:33 -0800
committerRosen Penev <rosenp@gmail.com>2022-01-17 21:12:20 -0800
commit06d5252474d3a29cc4f4d9b1fb8bcb5ce1c964ae (patch)
tree353582a2649444ef6493b3e65bf1a06b92721b1d /devel
parent7aec247dff0fb0b538cb622934c9febc8d2ce5ea (diff)
diffutils: update to 3.8
Fixes compilation with newer glibc. Ported gnulib patch from m4. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/diffutils/Makefile6
-rw-r--r--devel/diffutils/patches/010-ppc.patch13
2 files changed, 16 insertions, 3 deletions
diff --git a/devel/diffutils/Makefile b/devel/diffutils/Makefile
index ec8897710..a75a2b5d6 100644
--- a/devel/diffutils/Makefile
+++ b/devel/diffutils/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=diffutils
-PKG_VERSION:=3.7
-PKG_RELEASE:=3
+PKG_VERSION:=3.8
+PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/diffutils
-PKG_HASH:=b3a7a6221c3dc916085f0d205abf6b8e1ba443d4dd965118da364a1dc1cb3a26
+PKG_HASH:=a6bdd7d1b31266d11c4f4de6c1b748d4607ab0231af5188fc2533d0ae2438fec
PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
PKG_LICENSE:=GPL-3.0
diff --git a/devel/diffutils/patches/010-ppc.patch b/devel/diffutils/patches/010-ppc.patch
new file mode 100644
index 000000000..530b79fea
--- /dev/null
+++ b/devel/diffutils/patches/010-ppc.patch
@@ -0,0 +1,13 @@
+--- a/lib/sigsegv.c
++++ b/lib/sigsegv.c
+@@ -219,8 +219,8 @@ int libsigsegv_version = LIBSIGSEGV_VERS
+ # define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.gp_regs[1]
+ # else /* 32-bit */
+ /* both should be equivalent */
+-# if 0
+-# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.regs->gpr[1]
++# ifndef __GLIBC__
++# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.gregs[1]
+ # else
+ # define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.uc_regs->gregs[1]
+ # endif