aboutsummaryrefslogtreecommitdiff
path: root/devel/patch
diff options
context:
space:
mode:
authorRussell Senior <russell@personaltelco.net>2014-06-16 01:59:44 -0700
committerRussell Senior <russell@personaltelco.net>2014-06-16 02:01:28 -0700
commitaed796270aed1972551749b098b2992dbd0c7b5b (patch)
tree1db793b379b490930ffd955abf3326fa1b37fa29 /devel/patch
parenta1c86a0a846925d4b5e54c9d0374723d817740f6 (diff)
import GNU patch version 2.7.1
Signed-off-by: Russell Senior <russell@personaltelco.net>
Diffstat (limited to 'devel/patch')
-rw-r--r--devel/patch/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/devel/patch/Makefile b/devel/patch/Makefile
new file mode 100644
index 000000000..4b80804c8
--- /dev/null
+++ b/devel/patch/Makefile
@@ -0,0 +1,44 @@
+#
+# Copyright (C) 2008-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=patch
+PKG_VERSION:=2.7.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/patch
+PKG_MD5SUM:=95dd8d7e41dcbcecdd5cd88ef915378d
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/patch
+ SECTION:=devel
+ CATEGORY:=Development
+ TITLE:=patch
+ URL:=http://www.gnu.org/
+ MAINTAINER:=Russell Senior <russell@personaltelco.net>
+endef
+
+define Package/patch/description
+ The Patch package contains a program for modifying or creating files
+ by applying a "patch" file typically created by the diff program.
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ DESTDIR="$(PKG_INSTALL_DIR)" \
+ all install
+endef
+
+define Package/patch/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/patch $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,patch))