aboutsummaryrefslogtreecommitdiff
path: root/devel/m4/Makefile
diff options
context:
space:
mode:
authorHeinrich Schuchardt <xypron.glpk@gmx.de>2015-12-26 22:47:52 +0100
committerMichael Heimpold <mhei@heimpold.de>2015-12-27 12:23:11 +0100
commit89d35c260ef641fc795fee2603da9f04317b78e9 (patch)
treeec0267cd2277ca28cfcee6e1708f10d77bfd4c3c /devel/m4/Makefile
parent7d7bac5ff07d5574dad1746a25a4bf47a922816f (diff)
devel/m4: add new package (closes #2189)
GNU M4 is a prerequisite to run autoconf and automake. This patch packages the macro processor. This is a prerequisite for packaging autoconf and automake. Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de> [Fixed commit summary according to our best-practise] Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'devel/m4/Makefile')
-rw-r--r--devel/m4/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/devel/m4/Makefile b/devel/m4/Makefile
new file mode 100644
index 000000000..61be19b1b
--- /dev/null
+++ b/devel/m4/Makefile
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=m4
+PKG_VERSION:=1.4.17
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=@GNU/m4
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=a5e9954b1dae036762f7b13673a2cf76
+PKG_MAINTAINER:=Heinrich Schuchardt <xypron.glpk@gmx.de>
+PKG_LICENSE:=GPL-3.0+
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/m4
+ SECTION:=devel
+ CATEGORY:=Development
+ TITLE:=m4
+ URL:=https://www.gnu.org/software/m4/
+endef
+
+define Package/m4/description
+ GNU M4 is an implementation of the traditional Unix macro processor.
+ It is used by GNU Autoconf and Automake.
+endef
+
+define Package/m4/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/m4 $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,m4))