aboutsummaryrefslogtreecommitdiff
path: root/devel/lttng-modules
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-02-08 20:54:59 +0100
committerNicolas Thill <nico@openwrt.org>2015-02-08 20:55:48 +0100
commitdd313555f306ec98e0d7a87740eafbc4a3482657 (patch)
treee09b87fee2ebc466d68d8fd906949d8edb6e793e /devel/lttng-modules
parent0796ff4e3694166e2b0fd7808cbb78854c994f73 (diff)
lttng-modules: add new package
Signed-off-by: Nicolas Thill <nico@openwrt.org>
Diffstat (limited to 'devel/lttng-modules')
-rw-r--r--devel/lttng-modules/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/devel/lttng-modules/Makefile b/devel/lttng-modules/Makefile
new file mode 100644
index 000000000..bf5937125
--- /dev/null
+++ b/devel/lttng-modules/Makefile
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2013-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lttng-modules
+PKG_VERSION:=2.6.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=https://lttng.org/files/$(PKG_NAME)/
+PKG_MD5SUM:=a058ab037daaca293a54934d7b9f9c98
+
+PKG_LICENSE:=LGPL-2.1 GPL-2.0 MIT
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
+
+include $(INCLUDE_DIR)/kernel.mk
+include $(INCLUDE_DIR)/package.mk
+
+define KernelPackage/lttng
+ SUBMENU:=Other modules
+ TITLE:=Linux Trace Toolkit: next generation (kernel modules)
+ URL:=https://lttng.org/
+ DEPENDS:= @!TARGET_uml
+ FILES:= \
+ $(PKG_BUILD_DIR)/lttng-*.$(LINUX_KMOD_SUFFIX) \
+ $(PKG_BUILD_DIR)/lib/lttng-*.$(LINUX_KMOD_SUFFIX) \
+ $(PKG_BUILD_DIR)/probes/lttng-*.$(LINUX_KMOD_SUFFIX)
+endef
+
+define Build/Compile
+ $(MAKE) -C "$(LINUX_DIR)" \
+ ARCH="$(LINUX_KARCH)" \
+ CROSS_COMPILE="$(TARGET_CROSS)" \
+ SUBDIRS="$(PKG_BUILD_DIR)" \
+ V="$(V)" \
+ modules
+endef
+
+$(eval $(call KernelPackage,lttng))