aboutsummaryrefslogtreecommitdiff
path: root/devel/flex/patches
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2022-04-13 14:27:31 -0500
committerNick Hainke <vincent@systemli.org>2022-04-14 06:40:58 +0200
commitbaaf7f95cb5259724e28158510d9bcd152d4f693 (patch)
tree8a6a3f0d820db9c643f8920d4ccefd2be658365f /devel/flex/patches
parent2993c358ceb22131d756382fd83402a2c1016488 (diff)
flex: new package
Signed-off-by: W. Michael Petullo <mike@flyn.org>
Diffstat (limited to 'devel/flex/patches')
-rw-r--r--devel/flex/patches/100-disable-tests-docs.patch13
-rw-r--r--devel/flex/patches/200-build-AC_USE_SYSTEM_EXTENSIONS-in-configure.ac.patch27
2 files changed, 40 insertions, 0 deletions
diff --git a/devel/flex/patches/100-disable-tests-docs.patch b/devel/flex/patches/100-disable-tests-docs.patch
new file mode 100644
index 000000000..f7097f212
--- /dev/null
+++ b/devel/flex/patches/100-disable-tests-docs.patch
@@ -0,0 +1,13 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -43,10 +43,7 @@ EXTRA_DIST = \
+
+ SUBDIRS = \
+ src \
+- doc \
+- examples \
+ po \
+- tests \
+ tools
+
+ # Create the ChangeLog, but only if we're inside a git working directory
diff --git a/devel/flex/patches/200-build-AC_USE_SYSTEM_EXTENSIONS-in-configure.ac.patch b/devel/flex/patches/200-build-AC_USE_SYSTEM_EXTENSIONS-in-configure.ac.patch
new file mode 100644
index 000000000..7c3645c47
--- /dev/null
+++ b/devel/flex/patches/200-build-AC_USE_SYSTEM_EXTENSIONS-in-configure.ac.patch
@@ -0,0 +1,27 @@
+From 24fd0551333e7eded87b64dd36062da3df2f6380 Mon Sep 17 00:00:00 2001
+From: Explorer09 <explorer09@gmail.com>
+Date: Mon, 4 Sep 2017 10:47:33 +0800
+Subject: [PATCH] build: AC_USE_SYSTEM_EXTENSIONS in configure.ac.
+
+This would, e.g. define _GNU_SOURCE in config.h, enabling the
+reallocarray() prototype in glibc 2.26+ on Linux systems with that
+version of glibc.
+
+Fixes #241.
+---
+ configure.ac | 2 ++
+ 1 file changed, 2 insertions(+)
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -25,8 +25,10 @@
+ # autoconf requirements and initialization
+
+ AC_INIT([the fast lexical analyser generator],[2.6.4],[flex-help@lists.sourceforge.net],[flex])
++AC_PREREQ([2.60])
+ AC_CONFIG_SRCDIR([src/scan.l])
+ AC_CONFIG_AUX_DIR([build-aux])
++AC_USE_SYSTEM_EXTENSIONS
+ LT_INIT
+ AM_INIT_AUTOMAKE([1.11.3 -Wno-portability foreign check-news std-options dist-lzip parallel-tests subdir-objects])
+ AC_CONFIG_HEADER([src/config.h])