aboutsummaryrefslogtreecommitdiff
path: root/devel/diffutils
diff options
context:
space:
mode:
authorRoger <rogerdammit@gmail.com>2014-09-11 19:33:36 -0500
committerRoger <rogerdammit@gmail.com>2014-09-12 18:41:39 -0500
commit49439e629516ce0a5495b34f661d04bb94e0f55d (patch)
treebac0f2ec204ef591a0e057e451304ac09baac624 /devel/diffutils
parent890a47c49690cb2b5eaaf18e5a679430f363f614 (diff)
diffutils: add from old repo and update
Signed-off-by: Roger D <rogerdammit@gmail.com>
Diffstat (limited to 'devel/diffutils')
-rw-r--r--devel/diffutils/Makefile62
1 files changed, 62 insertions, 0 deletions
diff --git a/devel/diffutils/Makefile b/devel/diffutils/Makefile
new file mode 100644
index 000000000..33cdc1216
--- /dev/null
+++ b/devel/diffutils/Makefile
@@ -0,0 +1,62 @@
+#
+# Copyright (C) 2008-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=diffutils
+PKG_VERSION:=3.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@GNU/diffutils
+PKG_MD5SUM:=99180208ec2a82ce71f55b0d7389f1b3
+PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
+PKG_LICENSE:=GPL-3.0
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/diffutils
+ SECTION:=devel
+ CATEGORY:=Development
+ DEPENDS:=+USE_EGLIBC:librt
+ TITLE:=diffutils
+ URL:=http://www.gnu.org/software/diffutils/
+endef
+
+define Package/diffutils/description
+ The Diffutils package contains programs that show the differences between
+ files or directories.
+endef
+
+CONFIGURE_VARS += \
+ ac_cv_func_mempcpy=n
+TARGET_CFLAGS += --std=c99
+
+define Package/diffutils/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/{sdiff,diff3,diff,cmp} $(1)/usr/bin/
+endef
+
+define Package/diffutils/preinst
+#!/bin/sh
+for x in sdiff diff3 diff cmp; do
+ [ -L "$${IPKG_INSTROOT}/usr/bin/$$x" ] && rm -f "$${IPKG_INSTROOT}/usr/bin/$$x"
+done
+exit 0
+endef
+
+define Package/diffutils/postrm
+#!/bin/sh
+for x in sdiff diff3 diff cmp; do
+ /bin/busybox $$x -h 2>&1 | grep -q BusyBox && ln -sf ../../bin/busybox /usr/bin/$$x
+done
+exit 0
+endef
+
+$(eval $(call BuildPackage,diffutils))