aboutsummaryrefslogtreecommitdiff
path: root/devel/automake
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2016-10-03 14:52:59 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2016-10-16 17:49:13 +0200
commit06692e3c2454b18de73a78f247b26b6bef1bf984 (patch)
tree3099d0e3d03e1c4c4c4d1b08fb699523bf3ea958 /devel/automake
parent9e170ba2c0ef4cb6509420577f184985e2c2bd60 (diff)
automake: don't rely on STAGING_DIR_HOST
We're currently preparing a change in LEDE that will change the host staging dirs in a way that might break the sed commands used by the automake Makefile. Change the command in a way that doesn't depend on the path of the staging dir. While it would be nicer to modify the configure script to use the correct path in the first place, this doesn't work for the perl path, as perl is used in shebang lines and must thus be an absolute path. Some scripts are used both during build and on the target system, so fixing up the scripts in the install step seems like the best option. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'devel/automake')
-rw-r--r--devel/automake/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/devel/automake/Makefile b/devel/automake/Makefile
index 88cdbd14d..8357011c7 100644
--- a/devel/automake/Makefile
+++ b/devel/automake/Makefile
@@ -34,6 +34,8 @@ define Package/automake/description
with the GNU Coding Standards.
endef
+FIX_PATHS = $(SED) '1c \#!/usr/bin/perl' -e 's| /[^ ]*/bin/perl| /usr/bin/perl|g'
+
define Package/automake/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/automake-$(PKG_VERSION) \
@@ -42,10 +44,8 @@ define Package/automake/install
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/aclocal-$(PKG_VERSION) \
$(1)/usr/bin/aclocal-$(PKG_VERSION)
$(LN) aclocal-$(PKG_VERSION) $(1)/usr/bin/aclocal
- $(SED) 's|$(STAGING_DIR_HOST)|/usr|g' \
- $(1)/usr/bin/automake-$(PKG_VERSION)
- $(SED) 's|$(STAGING_DIR_HOST)|/usr|g' \
- $(1)/usr/bin/aclocal-$(PKG_VERSION)
+ $(FIX_PATHS) $(1)/usr/bin/automake-$(PKG_VERSION)
+ $(FIX_PATHS) $(1)/usr/bin/aclocal-$(PKG_VERSION)
$(INSTALL_DIR) $(1)/usr/share/automake-$(PKG_VERSION)
for dir in \