aboutsummaryrefslogtreecommitdiff
path: root/admin
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2023-08-17 14:30:58 +0200
committerTianling Shen <cnsztl@gmail.com>2023-08-23 08:35:02 +0800
commitf3a6491674ab451535e392b63e94a545abf3f292 (patch)
treec95292e297a3d1cfe8671cc74aa8f52c65409cdd /admin
parentd5b99f9e8a0958be7f8eef66515bd98e4a7b4d96 (diff)
bottom: New package
Bottom is a top/htop workalike with few additional features, written in rust. Signed-off-by: Luca Barbato <lu_zero@gentoo.org>
Diffstat (limited to 'admin')
-rw-r--r--admin/bottom/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/admin/bottom/Makefile b/admin/bottom/Makefile
new file mode 100644
index 000000000..bdd049a29
--- /dev/null
+++ b/admin/bottom/Makefile
@@ -0,0 +1,38 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Copyright (C) 2023 Luca Barbato
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bottom
+PKG_VERSION:=0.9.4
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/ClementTsang/bottom/tar.gz/$(PKG_VERSION)?
+PKG_HASH:=199123ef354bcabaa8a2e3b7b477b324f5b647d503a2599d08296733846eea6e
+
+PKG_MAINTAINER:=Luca Barbato <lu_zero@luminem.org>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_BUILD_DEPENDS:=rust/host
+
+include $(INCLUDE_DIR)/package.mk
+include ../../lang/rust/rust-package.mk
+
+define Package/bottom
+ SECTION:=admin
+ CATEGORY:=Administration
+ TITLE:=Interactive processes viewer
+ DEPENDS:=$(RUST_ARCH_DEPENDS)
+ URL:=https://github.com/ClementTsang/bottom
+endef
+
+define Package/bottom/description
+ A customizable cross-platform graphical process/system monitor
+ for the terminal.
+endef
+
+$(eval $(call RustBinPackage,bottom))
+$(eval $(call BuildPackage,bottom))