aboutsummaryrefslogtreecommitdiff
path: root/admin
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-04-22 15:38:27 -0700
committerGitHub <noreply@github.com>2020-04-22 15:38:27 -0700
commite21a063ecb1e5260a557cbe594293789de5b75ae (patch)
tree10ce79500bf069597904c27c5e1e6ee28749aaf1 /admin
parent03766feb80dfb97ec115b068f80d06ab3c7585f9 (diff)
parentb48b1449789579cab72f51328415755f10ce1a40 (diff)
Merge pull request #11834 from sumpfralle/master
muninlite: update to 2.0.1
Diffstat (limited to 'admin')
-rw-r--r--admin/muninlite/Makefile27
-rw-r--r--admin/muninlite/files/etc/xinetd.d/muninlite (renamed from admin/muninlite/files/etc/xinetd.d/munin)4
-rw-r--r--admin/muninlite/patches/001-fix_disks.patch10
-rw-r--r--admin/muninlite/patches/002-hostname.patch11
-rw-r--r--admin/muninlite/patches/100-fix-no-ethtool.patch21
-rw-r--r--admin/muninlite/patches/110-fix-uptime-days.patch12
-rw-r--r--admin/muninlite/patches/200-add-tap-dev.patch20
-rw-r--r--admin/muninlite/patches/210-add-bridge-devs.patch24
-rw-r--r--admin/muninlite/patches/220-modify-ifname-parser.patch22
-rw-r--r--admin/muninlite/patches/230-fix-available-interface-parsing.patch20
-rw-r--r--admin/muninlite/patches/240-fix-irqstats.patch10
11 files changed, 13 insertions, 168 deletions
diff --git a/admin/muninlite/Makefile b/admin/muninlite/Makefile
index 522f534ed..39e043078 100644
--- a/admin/muninlite/Makefile
+++ b/admin/muninlite/Makefile
@@ -8,12 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=muninlite
-PKG_VERSION:=1.0.4
-PKG_RELEASE:=10
+PKG_VERSION:=2.0.1
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_HASH:=736482dd6d6849d014d975b1f5794f20dda6e123dbba2d8c2f169c8e787e6f7e
+PKG_SOURCE_URL:=https://github.com/munin-monitoring/$(PKG_NAME)/releases/download/$(PKG_VERSION)/
+PKG_HASH:=8277ccd146b4fc5b57602dba3f5612c7d6f840b4c3ee2ff3756ff4b3d8527966
+
+PKG_MAINTAINER:=Jonathan McCrohan <jmccrohan@gmail.com>
PKG_LICENSE:=GPL-2.0-or-later
PKG_LICENSE_FILES:=LICENSE
@@ -24,8 +26,7 @@ define Package/muninlite
CATEGORY:=Administration
DEPENDS:=+xinetd
TITLE:=Munin node implemented in shell
- URL:=http://sourceforge.net/projects/muninlite/
- PKG_MAINTAINER:=Jonathan McCrohan <jmccrohan@gmail.com>
+ URL:=https://github.com/munin-monitoring/muninlite
endef
define Package/muninlite/Default/description
@@ -35,20 +36,14 @@ endef
define Package/muninlite/install
$(INSTALL_DIR) $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/munin-node $(1)/usr/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/muninlite $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc/xinetd.d
- $(INSTALL_DATA) ./files/etc/xinetd.d/munin $(1)/etc/xinetd.d/
+ $(INSTALL_DATA) ./files/etc/xinetd.d/muninlite $(1)/etc/xinetd.d/
+ $(INSTALL_DIR) $(1)/etc/munin/plugins
endef
define Package/muninlite/conffiles
-/etc/xinetd.d/munin
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR)
+/etc/xinetd.d/muninlite
endef
$(eval $(call BuildPackage,muninlite))
diff --git a/admin/muninlite/files/etc/xinetd.d/munin b/admin/muninlite/files/etc/xinetd.d/muninlite
index 012d71b9f..d62dc103c 100644
--- a/admin/muninlite/files/etc/xinetd.d/munin
+++ b/admin/muninlite/files/etc/xinetd.d/muninlite
@@ -1,10 +1,10 @@
-service munin
+service muninlite
{
socket_type = stream
protocol = tcp
wait = no
user = root
group = root
- server = /usr/sbin/munin-node
+ server = /usr/sbin/muninlite
disable = no
}
diff --git a/admin/muninlite/patches/001-fix_disks.patch b/admin/muninlite/patches/001-fix_disks.patch
deleted file mode 100644
index a2264a8f6..000000000
--- a/admin/muninlite/patches/001-fix_disks.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/plugins/df
-+++ b/plugins/df
-@@ -19,6 +19,6 @@ fetch_df() {
- do
- PINFO=$(df -P $PART | tail -1);
- PNAME=$(echo $PINFO | cut -d\ -f1 | sed 's/[\/.-]/_/g')
-- echo "$PNAME.value" $(echo $PINFO | cut -f5 -d\ | sed -e 's/\%//g')
-+ echo "$PNAME.value" $(echo $PINFO | sed -e 's/\%//g' -e 's/ */ /g' | cut -f5 -d' ')
- done
- }
diff --git a/admin/muninlite/patches/002-hostname.patch b/admin/muninlite/patches/002-hostname.patch
deleted file mode 100644
index 5d871683c..000000000
--- a/admin/muninlite/patches/002-hostname.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/munin-node.in
-+++ b/munin-node.in
-@@ -113,7 +113,7 @@ PLUGINS=$RES
-
- # ===== MAIN LOOP =====
- FUNCTIONS="list nodes config fetch version quit"
--HOSTNAME=$(hostname -f 2>/dev/null || hostname)
-+HOSTNAME=$(/sbin/uci get "system.@system[0].hostname" 2>/dev/null || cat /proc/sys/kernel/hostname)
- echo "# munin node at $HOSTNAME"
- while read arg0 arg1
- do
diff --git a/admin/muninlite/patches/100-fix-no-ethtool.patch b/admin/muninlite/patches/100-fix-no-ethtool.patch
deleted file mode 100644
index 88f7e3056..000000000
--- a/admin/muninlite/patches/100-fix-no-ethtool.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/plugins/if_
-+++ b/plugins/if_
-@@ -15,10 +15,14 @@ config_if() {
- echo "up.min 0"
- echo "up.negative down"
- echo "up.cdef up,8,*"
-- if ethtool $1 | grep -q Speed; then
-- MAX=$(($(ethtool $1 | grep Speed | sed -e 's/[[:space:]]\{1,\}/ /g' -e 's/^ //' -e 's/M.*//' | cut -d\ -f2) * 1000000))
-- echo "up.max $MAX"
-- echo "down.max $MAX"
-+ if [ -n "$(which ethtool)" ]; then
-+ if [ -x "$(which ethtool)" ]; then
-+ if ethtool $1 | grep -q Speed; then
-+ MAX=$(($(ethtool $1 | grep Speed | sed -e 's/[[:space:]]\{1,\}/ /g' -e 's/^ //' -e 's/M.*//' | cut -d\ -f2) * 1000000))
-+ echo "up.max $MAX"
-+ echo "down.max $MAX"
-+ fi
-+ fi
- fi
- }
- fetch_if() {
diff --git a/admin/muninlite/patches/110-fix-uptime-days.patch b/admin/muninlite/patches/110-fix-uptime-days.patch
deleted file mode 100644
index d9aa43f4a..000000000
--- a/admin/muninlite/patches/110-fix-uptime-days.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/plugins/uptime
-+++ b/plugins/uptime
-@@ -4,8 +4,7 @@ config_uptime() {
- echo "graph_vlabel uptime in days"
- echo "uptime.label uptime"
- echo "uptime.draw AREA"
-- echo "uptime.cdef uptime,86400,/"
- }
- fetch_uptime() {
-- echo "uptime.value" $(cut -d\ -f1 /proc/uptime)
-+ awk '{printf "uptime.value %.2f",$1/86400; print ""}' /proc/uptime
- }
diff --git a/admin/muninlite/patches/200-add-tap-dev.patch b/admin/muninlite/patches/200-add-tap-dev.patch
deleted file mode 100644
index fa46ce6b3..000000000
--- a/admin/muninlite/patches/200-add-tap-dev.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/munin-node.in
-+++ b/munin-node.in
-@@ -72,7 +72,7 @@ RES=""
- for PLUG in $PLUGINS
- do
- if [ "$PLUG" = "if_" ]; then
-- for INTER in $(grep '^ *\(ppp\|eth\|wlan\|ath\|ra\|ipsec\)\([^:]\)\{1,\}:' /proc/net/dev | cut -f1 -d: | sed 's/ //g');
-+ for INTER in $(grep '^ *\(ppp\|eth\|wlan\|ath\|ra\|ipsec\|tap\)\([^:]\)\{1,\}:' /proc/net/dev | cut -f1 -d: | sed 's/ //g');
- do
- INTERRES=$(echo $INTER | sed 's/\./VLAN/')
- RES="$RES if_$INTERRES"
-@@ -80,7 +80,7 @@ do
- eval "config_if_${INTERRES}() { config_if $INTER $@; };"
- done
- elif [ "$PLUG" = "if_err_" ]; then
-- for INTER in $(grep '^ *\(ppp\|eth\|wlan\|ath\|ra\|ipsec\)\([^:]\)\{1,\}:' /proc/net/dev | cut -f1 -d: | sed 's/ //g');
-+ for INTER in $(grep '^ *\(ppp\|eth\|wlan\|ath\|ra\|ipsec\|tap\)\([^:]\)\{1,\}:' /proc/net/dev | cut -f1 -d: | sed 's/ //g');
- do
- INTERRES=$(echo $INTER | sed 's/\./VLAN/')
- RES="$RES if_err_$INTERRES"
diff --git a/admin/muninlite/patches/210-add-bridge-devs.patch b/admin/muninlite/patches/210-add-bridge-devs.patch
deleted file mode 100644
index 1a76e971d..000000000
--- a/admin/muninlite/patches/210-add-bridge-devs.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/munin-node.in
-+++ b/munin-node.in
-@@ -72,17 +72,17 @@ RES=""
- for PLUG in $PLUGINS
- do
- if [ "$PLUG" = "if_" ]; then
-- for INTER in $(grep '^ *\(ppp\|eth\|wlan\|ath\|ra\|ipsec\|tap\)\([^:]\)\{1,\}:' /proc/net/dev | cut -f1 -d: | sed 's/ //g');
-+ for INTER in $(grep '^ *\(ppp\|eth\|wlan\|ath\|ra\|ipsec\|tap\|br-\)\([^:]\)\{1,\}:' /proc/net/dev | cut -f1 -d: | sed 's/ //g');
- do
-- INTERRES=$(echo $INTER | sed 's/\./VLAN/')
-+ INTERRES=$(echo $INTER | sed -e 's/\./VLAN/' -e 's/\-/_/')
- RES="$RES if_$INTERRES"
- eval "fetch_if_${INTERRES}() { fetch_if $INTER $@; };"
- eval "config_if_${INTERRES}() { config_if $INTER $@; };"
- done
- elif [ "$PLUG" = "if_err_" ]; then
-- for INTER in $(grep '^ *\(ppp\|eth\|wlan\|ath\|ra\|ipsec\|tap\)\([^:]\)\{1,\}:' /proc/net/dev | cut -f1 -d: | sed 's/ //g');
-+ for INTER in $(grep '^ *\(ppp\|eth\|wlan\|ath\|ra\|ipsec\|tap\|br-\)\([^:]\)\{1,\}:' /proc/net/dev | cut -f1 -d: | sed 's/ //g');
- do
-- INTERRES=$(echo $INTER | sed 's/\./VLAN/')
-+ INTERRES=$(echo $INTER | sed -e 's/\./VLAN/' -e 's/\-/_/')
- RES="$RES if_err_$INTERRES"
- eval "fetch_if_err_${INTERRES}() { fetch_if_err $INTER $@; };"
- eval "config_if_err_${INTERRES}() { config_if_err $INTER $@; };"
diff --git a/admin/muninlite/patches/220-modify-ifname-parser.patch b/admin/muninlite/patches/220-modify-ifname-parser.patch
deleted file mode 100644
index 6a2ba236f..000000000
--- a/admin/muninlite/patches/220-modify-ifname-parser.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/plugins/if_
-+++ b/plugins/if_
-@@ -26,7 +26,7 @@ config_if() {
- fi
- }
- fetch_if() {
-- IINFO=$(grep "$1:" /proc/net/dev | cut -d: -f2 | sed -e 's/ / /g')
-+ IINFO=$(grep "$1:" /proc/net/dev | cut -d: -f2 | sed -e 's/ */ /g' -e 's/^[ \t]*//')
- echo "down.value" $(echo $IINFO | cut -d\ -f1)
- echo "up.value" $(echo $IINFO | cut -d\ -f9)
- }
---- a/plugins/if_err_
-+++ b/plugins/if_err_
-@@ -15,7 +15,7 @@ config_if_err() {
- echo "trans.warning 1"
- }
- fetch_if_err() {
-- IINFO=$(grep "$1:" /proc/net/dev | cut -d: -f2 | sed -e 's/ / /g')
-+ IINFO=$(grep "$1:" /proc/net/dev | cut -d: -f2 | sed -e 's/ */ /g' -e 's/^[ \t]*//')
- echo "rcvd.value" $(echo $IINFO | cut -d\ -f3)
- echo "trans.value" $(echo $IINFO | cut -d\ -f11)
- }
diff --git a/admin/muninlite/patches/230-fix-available-interface-parsing.patch b/admin/muninlite/patches/230-fix-available-interface-parsing.patch
deleted file mode 100644
index 2f227e58c..000000000
--- a/admin/muninlite/patches/230-fix-available-interface-parsing.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/munin-node.in
-+++ b/munin-node.in
-@@ -72,7 +72,7 @@ RES=""
- for PLUG in $PLUGINS
- do
- if [ "$PLUG" = "if_" ]; then
-- for INTER in $(grep '^ *\(ppp\|eth\|wlan\|ath\|ra\|ipsec\|tap\|br-\)\([^:]\)\{1,\}:' /proc/net/dev | cut -f1 -d: | sed 's/ //g');
-+ for INTER in $(grep -E '^ *(ppp|eth|wlan|ath|ra|ipsec|tap|br-)[^:]{1,}:' /proc/net/dev | cut -f1 -d: | sed 's/ //g');
- do
- INTERRES=$(echo $INTER | sed -e 's/\./VLAN/' -e 's/\-/_/')
- RES="$RES if_$INTERRES"
-@@ -80,7 +80,7 @@ do
- eval "config_if_${INTERRES}() { config_if $INTER $@; };"
- done
- elif [ "$PLUG" = "if_err_" ]; then
-- for INTER in $(grep '^ *\(ppp\|eth\|wlan\|ath\|ra\|ipsec\|tap\|br-\)\([^:]\)\{1,\}:' /proc/net/dev | cut -f1 -d: | sed 's/ //g');
-+ for INTER in $(grep -E '^ *(ppp|eth|wlan|ath|ra|ipsec|tap|br-)[^:]{1,}:' /proc/net/dev | cut -f1 -d: | sed 's/ //g');
- do
- INTERRES=$(echo $INTER | sed -e 's/\./VLAN/' -e 's/\-/_/')
- RES="$RES if_err_$INTERRES"
diff --git a/admin/muninlite/patches/240-fix-irqstats.patch b/admin/muninlite/patches/240-fix-irqstats.patch
deleted file mode 100644
index 4e2fb23ed..000000000
--- a/admin/muninlite/patches/240-fix-irqstats.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/plugins/irqstats 2007-11-30 11:39:08.000000000 +0100
-+++ b/plugins/irqstats 2018-08-29 08:20:50.809468406 +0200
-@@ -1,6 +1,6 @@
- config_irqstats() {
- echo "graph_title Individual interrupts
--graph_args --base 1000 -l 0;
-+graph_args --base 1000 -l 0
- graph_vlabel interrupts / \${graph_period}
- graph_category system"
- CPUS=$(grep 'CPU[0-9]' /proc/interrupts | wc -w)