aboutsummaryrefslogtreecommitdiff
path: root/admin
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-07-01 16:39:55 -0700
committerRosen Penev <rosenp@gmail.com>2020-07-02 19:22:00 -0700
commitde6471014a6d7bcb1a4ffcb50a68215f5f77e276 (patch)
treeb645c0035f765b2a0a0a7b4aceb774539a935691 /admin
parent371d7b3892ee596bbb2e68a28ed2c41c218730cb (diff)
htop: fix compilation with GCC10
Patch taken from upstream. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'admin')
-rw-r--r--admin/htop/Makefile2
-rw-r--r--admin/htop/patches/010-gcc10.patch38
2 files changed, 39 insertions, 1 deletions
diff --git a/admin/htop/Makefile b/admin/htop/Makefile
index 3e3d9f641..470aeaa63 100644
--- a/admin/htop/Makefile
+++ b/admin/htop/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=htop
PKG_VERSION:=2.2.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://hisham.hm/htop/releases/$(PKG_VERSION)/
diff --git a/admin/htop/patches/010-gcc10.patch b/admin/htop/patches/010-gcc10.patch
new file mode 100644
index 000000000..246e6f761
--- /dev/null
+++ b/admin/htop/patches/010-gcc10.patch
@@ -0,0 +1,38 @@
+From ee711740d2809e7aa3ebd57d58bfc02b1e9b034b Mon Sep 17 00:00:00 2001
+From: David Seifert <soap@gentoo.org>
+Date: Thu, 23 Jan 2020 17:27:10 +0100
+Subject: [PATCH] Fix GCC 10 switch to `-fno-common` default
+
+---
+ CRT.h | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/CRT.h b/CRT.h
+index 933fe068..65998ac6 100644
+--- a/CRT.h
++++ b/CRT.h
+@@ -140,7 +140,7 @@ extern const char **CRT_treeStr;
+
+ extern int CRT_delay;
+
+-int* CRT_colors;
++extern int* CRT_colors;
+
+ extern int CRT_colorSchemes[LAST_COLORSCHEME][LAST_COLORELEMENT];
+
+@@ -150,13 +150,13 @@ extern int CRT_scrollHAmount;
+
+ extern int CRT_scrollWheelVAmount;
+
+-char* CRT_termType;
++extern char* CRT_termType;
+
+ // TODO move color scheme to Settings, perhaps?
+
+ extern int CRT_colorScheme;
+
+-void *backtraceArray[128];
++extern void *backtraceArray[128];
+
+ #if HAVE_SETUID_ENABLED
+