aboutsummaryrefslogtreecommitdiff
path: root/admin
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2022-10-13 18:14:13 +0800
committerNick Hainke <vincent@systemli.org>2022-10-19 09:30:12 +0200
commitd04b590fc215d75ca8a80a21297bba311c2cb151 (patch)
treef3b998a94c7d9a372d82a30ceec21effed4930b8 /admin
parent5801b0134ae857d1ba4563f327df593b603b4395 (diff)
btop: add new package
Resource monitor that shows usage and stats for processor, memory, disks, network and processes. Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'admin')
-rw-r--r--admin/btop/Makefile47
-rw-r--r--admin/btop/test.sh3
2 files changed, 50 insertions, 0 deletions
diff --git a/admin/btop/Makefile b/admin/btop/Makefile
new file mode 100644
index 000000000..557393d78
--- /dev/null
+++ b/admin/btop/Makefile
@@ -0,0 +1,47 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=btop
+PKG_VERSION:=1.2.12
+PKG_RELEASE:=$(AUTORELEASE)
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL=https://codeload.github.com/aristocratos/btop/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=158112184372ff93de68700ad7de12f91be0542c0ecf75ffb002326ecbb3ca76
+
+PKG_MAINTAINER:=Tianling Shen <cnsztl@immortalwrt.org>
+PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_BUILD_PARALLEL:=1
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/btop
+ SECTION:=admin
+ CATEGORY:=Administration
+ TITLE:=A monitor of resources
+ URL:=https://github.com/aristocratos/btop
+ DEPENDS:=+libstdcpp
+endef
+
+define Package/btop/description
+ Resource monitor that shows usage and stats for processor, memory,
+ disks, network and processes.
+
+ C++ version and continuation of bashtop and bpytop.
+endef
+
+MAKE_FLAGS+= \
+ PLATFORM=Linux \
+ OPTFLAGS="$(TARGET_CXXFLAGS)" \
+ LDCXXFLAGS="$(TARGET_LDFLAGS) -pthread"
+
+define Package/btop/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/local/bin/btop $(1)/usr/bin/
+ $(INSTALL_DIR) $(1)/usr/share
+ $(CP) $(PKG_INSTALL_DIR)/usr/local/share/btop $(1)/usr/share/
+endef
+
+$(eval $(call BuildPackage,btop))
diff --git a/admin/btop/test.sh b/admin/btop/test.sh
new file mode 100644
index 000000000..b7b21ab7c
--- /dev/null
+++ b/admin/btop/test.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+btop --version | grep "$PKG_VERSION"