aboutsummaryrefslogtreecommitdiff
path: root/admin
diff options
context:
space:
mode:
authorJohn Audia <graysky@archlinux.us>2020-08-28 09:28:18 -0400
committerJohn Audia <graysky@archlinux.us>2020-08-28 17:12:04 -0400
commitacbdaf863fd8e2d6896073181a788b4ba106b43d (patch)
tree079ae72192a45a6db71938fe17f5fe4bfd8c9de6 /admin
parent41d9951575fe890fb91f1e3defa1dd0011dc3815 (diff)
htop: update to 3.0.0-1
new upstream, new release taken from ChangeLog[1]: New maintainers - after a prolonged period of inactivity from Hisham, the creator and original maintainer, a team of community maintainers have volunteered to take over a fork at https://htop.dev and https://github.com/htop-dev to keep the project going. 1. https://github.com/htop-dev/htop/blob/master/ChangeLog Signed-off-by: John Audia <graysky@archlinux.us>
Diffstat (limited to 'admin')
-rw-r--r--admin/htop/Makefile12
-rw-r--r--admin/htop/patches/010-gcc10.patch38
2 files changed, 7 insertions, 43 deletions
diff --git a/admin/htop/Makefile b/admin/htop/Makefile
index 470aeaa63..836e2eddf 100644
--- a/admin/htop/Makefile
+++ b/admin/htop/Makefile
@@ -8,17 +8,19 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=htop
-PKG_VERSION:=2.2.0
-PKG_RELEASE:=3
+PKG_VERSION:=3.0.0
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://hisham.hm/htop/releases/$(PKG_VERSION)/
-PKG_HASH:=d9d6826f10ce3887950d709b53ee1d8c1849a70fa38e91d5896ad8cbc6ba3c57
+PKG_SOURCE_URL:=https://codeload.github.com/htop-dev/htop/tar.gz/$(PKG_VERSION)?
+PKG_HASH:=1c0661f0ae5f4e2874da250b60cd515e4ac4c041583221adfe95f10e18d1a4e6
-PKG_LICENSE:=GPL-2.0
+PKG_LICENSE:=GPL-2.0-or-later
PKG_LICENSE_FILES:=COPYING
PKG_CPE_ID:=cpe:/a:htop:htop
+
+PKG_FIXUP:=autoreconf
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
diff --git a/admin/htop/patches/010-gcc10.patch b/admin/htop/patches/010-gcc10.patch
deleted file mode 100644
index 246e6f761..000000000
--- a/admin/htop/patches/010-gcc10.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From ee711740d2809e7aa3ebd57d58bfc02b1e9b034b Mon Sep 17 00:00:00 2001
-From: David Seifert <soap@gentoo.org>
-Date: Thu, 23 Jan 2020 17:27:10 +0100
-Subject: [PATCH] Fix GCC 10 switch to `-fno-common` default
-
----
- CRT.h | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/CRT.h b/CRT.h
-index 933fe068..65998ac6 100644
---- a/CRT.h
-+++ b/CRT.h
-@@ -140,7 +140,7 @@ extern const char **CRT_treeStr;
-
- extern int CRT_delay;
-
--int* CRT_colors;
-+extern int* CRT_colors;
-
- extern int CRT_colorSchemes[LAST_COLORSCHEME][LAST_COLORELEMENT];
-
-@@ -150,13 +150,13 @@ extern int CRT_scrollHAmount;
-
- extern int CRT_scrollWheelVAmount;
-
--char* CRT_termType;
-+extern char* CRT_termType;
-
- // TODO move color scheme to Settings, perhaps?
-
- extern int CRT_colorScheme;
-
--void *backtraceArray[128];
-+extern void *backtraceArray[128];
-
- #if HAVE_SETUID_ENABLED
-