aboutsummaryrefslogtreecommitdiff
path: root/admin
diff options
context:
space:
mode:
authorScott Roberts <ttocsr@gmail.com>2020-06-18 19:50:24 -0600
committerScott Roberts <ttocsr@gmail.com>2020-06-19 07:55:35 -0600
commit9694ae7afa5458d0fd2131b190fe83708d76c297 (patch)
tree754e85fc1814aa2687ef9187bd8883dacdbfa07c /admin
parent4426e4c69b3edbc7dca679c71769c690318b4659 (diff)
zabbix: update to 5.0 LTS
Updated to 5.0 LTS version. Removed 120-uclibc-res.patch Frontend moved from frontend to ui zabbix-proxy added libevent dependencie refresh patches Compile tested: aarch64 cortex-a53 Run tested: aarch64 cortex-a53 Signed-off-by: Scott Roberts <ttocsr@gmail.com>
Diffstat (limited to 'admin')
-rw-r--r--admin/zabbix/Makefile12
-rw-r--r--admin/zabbix/patches/010-change-agentd-config.patch8
-rw-r--r--admin/zabbix/patches/110-reproducible-builds.patch2
-rw-r--r--admin/zabbix/patches/120-uclibc-res.patch23
4 files changed, 11 insertions, 34 deletions
diff --git a/admin/zabbix/Makefile b/admin/zabbix/Makefile
index ba8a97f71..ca189c140 100644
--- a/admin/zabbix/Makefile
+++ b/admin/zabbix/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=zabbix
-PKG_VERSION:=4.0.16
-PKG_RELEASE:=3
+PKG_VERSION:=5.0.1
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/zabbix
-PKG_HASH:=a8d7e18230e62a7bd3fd9af5830a2b1b22818468b5da3deb673865ce40dc4d42
+PKG_SOURCE_URL:=https://cdn.zabbix.com/zabbix/sources/stable/5.0/
+PKG_HASH:=20a19e5cf2354ffcbbe24521b04becfc9875e57289c00da71999de60c4a853b6
PKG_MAINTAINER:=Etienne CHAMPETIER <champetier.etienne@gmail.com>
PKG_LICENSE:=GPL-2.0
@@ -127,7 +127,7 @@ endef
define Package/zabbix-proxy
$(call Package/zabbix/Default)
TITLE+= proxy
- DEPENDS += +ZABBIX_POSTGRESQL:libpq +ZABBIX_MYSQL:libmariadbclient
+ DEPENDS += +ZABBIX_POSTGRESQL:libpq +ZABBIX_MYSQL:libmariadbclient +libevent2
endef
define Package/zabbix-extra-mac80211/description
@@ -298,7 +298,7 @@ endef
define Package/zabbix-server-frontend/install
$(INSTALL_DIR) $(1)/www/zabbix
- $(CP) $(PKG_BUILD_DIR)/frontends/php/* $(1)/www/zabbix
+ $(CP) $(PKG_BUILD_DIR)/ui/* $(1)/www/zabbix
endef
define Package/zabbix-proxy/install
diff --git a/admin/zabbix/patches/010-change-agentd-config.patch b/admin/zabbix/patches/010-change-agentd-config.patch
index 284ff0552..f76282748 100644
--- a/admin/zabbix/patches/010-change-agentd-config.patch
+++ b/admin/zabbix/patches/010-change-agentd-config.patch
@@ -27,7 +27,7 @@
### Option: LogFileSize
# Maximum size of log file in MB.
# 0 - disable automatic log rotation.
-@@ -117,6 +114,7 @@ Server=127.0.0.1
+@@ -138,6 +135,7 @@ Server=127.0.0.1
# Range: 0-100
# Default:
# StartAgents=3
@@ -35,7 +35,7 @@
##### Active checks related
-@@ -132,8 +130,6 @@ Server=127.0.0.1
+@@ -153,8 +151,6 @@ Server=127.0.0.1
# Default:
# ServerActive=
@@ -44,7 +44,7 @@
### Option: Hostname
# Unique, case sensitive hostname.
# Required for active checks and must match hostname as configured on the server.
-@@ -143,8 +139,6 @@ ServerActive=127.0.0.1
+@@ -164,8 +160,6 @@ ServerActive=127.0.0.1
# Default:
# Hostname=
@@ -53,7 +53,7 @@
### Option: HostnameItem
# Item used for generating Hostname if it is undefined. Ignored if Hostname is defined.
# Does not support UserParameters or aliases.
-@@ -262,8 +256,8 @@ Hostname=Zabbix server
+@@ -305,8 +299,8 @@ Hostname=Zabbix server
# Include=
# Include=/usr/local/etc/zabbix_agentd.userparams.conf
diff --git a/admin/zabbix/patches/110-reproducible-builds.patch b/admin/zabbix/patches/110-reproducible-builds.patch
index 764417a20..72f92acc8 100644
--- a/admin/zabbix/patches/110-reproducible-builds.patch
+++ b/admin/zabbix/patches/110-reproducible-builds.patch
@@ -7,5 +7,5 @@
- printf("Revision %s %s, compilation time: %s %s\n\n", ZABBIX_REVISION, ZABBIX_REVDATE, __DATE__, __TIME__);
+ printf("Revision %s %s\n\n", ZABBIX_REVISION, ZABBIX_REVDATE);
puts(copyright_message);
- #if defined(HAVE_POLARSSL) || defined(HAVE_GNUTLS) || defined(HAVE_OPENSSL)
+ #if defined(HAVE_GNUTLS) || defined(HAVE_OPENSSL)
printf("\n");
diff --git a/admin/zabbix/patches/120-uclibc-res.patch b/admin/zabbix/patches/120-uclibc-res.patch
deleted file mode 100644
index d88e0085e..000000000
--- a/admin/zabbix/patches/120-uclibc-res.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/src/libs/zbxsysinfo/common/net.c
-+++ b/src/libs/zbxsysinfo/common/net.c
-@@ -547,7 +547,7 @@ static int dns_query(AGENT_REQUEST *request, AGENT_RESULT *result, int short_ans
- return SYSINFO_RET_FAIL;
- }
-
--#if defined(HAVE_RES_NINIT) && !defined(_AIX)
-+#if defined(HAVE_RES_NINIT) && !defined(_AIX) && !defined(__UCLIBC__)
- if (-1 == (res = res_nmkquery(&res_state_local, QUERY, zone, C_IN, type, NULL, 0, NULL, buf, sizeof(buf))))
- #else
- if (-1 == (res = res_mkquery(QUERY, zone, C_IN, type, NULL, 0, NULL, buf, sizeof(buf))))
-@@ -643,7 +643,11 @@ static int dns_query(AGENT_REQUEST *request, AGENT_RESULT *result, int short_ans
- res_state_local.retrans = retrans;
- res_state_local.retry = retry;
-
-+#ifndef __UCLIBC__
- res = res_nsend(&res_state_local, buf, res, answer.buffer, sizeof(answer.buffer));
-+#else
-+ res = res_search(*res_state_local.dnsrch, res, 0, answer.buffer, sizeof(answer.buffer));
-+#endif
-
- # ifdef HAVE_RES_U_EXT /* Linux */
- if (NULL != ip && '\0' != *ip && AF_INET6 == ip_type)