aboutsummaryrefslogtreecommitdiff
path: root/admin
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2018-11-08 19:44:09 +0100
committerDaniel Engberg <daniel.engberg.lists@pyret.net>2018-11-08 19:44:09 +0100
commit8e1d493093bdaf959dc116e50ecb9fd6207472a1 (patch)
tree6a1ce22efab795ae2cb60ff4a69a04304b16c0b1 /admin
parenta20433e8135b85bc206eb2c52fd0ab74cf677c23 (diff)
netdata: Update to 1.11.0
Update netdata to 1.11.0 Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
Diffstat (limited to 'admin')
-rw-r--r--admin/netdata/Makefile50
-rw-r--r--admin/netdata/patches/001-disable-plugins-by-default.patch26
-rw-r--r--admin/netdata/patches/001-disable_external_plugins_by_default.patch22
-rw-r--r--admin/netdata/patches/002-force-python3.patch12
4 files changed, 68 insertions, 42 deletions
diff --git a/admin/netdata/Makefile b/admin/netdata/Makefile
index b06add37b..f0bd96a0e 100644
--- a/admin/netdata/Makefile
+++ b/admin/netdata/Makefile
@@ -8,18 +8,20 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=netdata
-PKG_VERSION:=1.10.0
-PKG_RELEASE:=2
+PKG_VERSION:=1.11.0
+PKG_RELEASE:=1
PKG_MAINTAINER:=
PKG_LICENSE:=GPL-3.0
PKG_LICENSE_FILES:=COPYING
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=https://github.com/firehol/netdata/releases/download/v$(PKG_VERSION)
-PKG_HASH:=0514fc002c5c5fb730156b3fe928965b22327833c6c17e22b7097eda657e77a2
+PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/netdata/netdata/releases/download/v$(PKG_VERSION)
+PKG_HASH:=c42c8411c22c72e3e52fed38d7b9537bcfaf568d01e9c1e35ec645490627619d
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)_rolling
PKG_INSTALL:=1
PKG_FIXUP:=autoreconf
+PKG_USE_MIPS16:=0
include $(INCLUDE_DIR)/package.mk
@@ -34,25 +36,42 @@ endef
define Package/netdata/description
netdata is a highly optimized Linux daemon providing real-time performance
monitoring for Linux systems, applications and SNMP devices over the web.
+
+ If you want to use Python plugins install python3, python3-yaml and
+ python3-urllib3 however urllib3 isn't packaged yet (needs a PR on GitHub)
endef
TARGET_CFLAGS := $(filter-out -O%,$(TARGET_CFLAGS))
TARGET_CFLAGS += -ffunction-sections -fdata-sections -O3
TARGET_LDFLAGS += -Wl,--gc-sections
-CONFIGURE_ARGS += --with-zlib --with-math --disable-x86-sse --disable-lto
+CONFIGURE_ARGS += \
+ --with-zlib \
+ --with-math \
+ --disable-x86-sse \
+ --enable-lto \
+ --without-libcap \
+ --disable-plugin-nfacct
define Package/netdata/conffiles
/etc/netdata/
endef
define Package/netdata/install
- mkdir -p $(1)/etc/netdata
+ $(INSTALL_DIR) $(1)/etc/netdata/custom-plugins.d
$(CP) $(PKG_INSTALL_DIR)/etc/netdata $(1)/etc
$(CP) ./files/netdata.conf $(1)/etc/netdata
- mkdir -p $(1)/etc/netdata/custom-plugins.d
-
- mkdir -p $(1)/usr/share/netdata
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/netdata $(1)/usr/lib
+ $(CP) $(1)/usr/lib/netdata/conf.d/fping.conf $(1)/etc
+ $(CP) $(1)/usr/lib/netdata/conf.d/health_alarm_notify.conf $(1)/etc
+ rm -rf $(1)/usr/lib/netdata/python.d/python_modules/pyyaml2
+ rm -rf $(1)/usr/lib/netdata/python.d/python_modules/pyyaml3
+ rm -rf $(1)/usr/lib/netdata/python.d/python_modules/urllib3
+ $(CP) $(1)/usr/lib/netdata/plugins.d/tc-qos-helper.sh $(1)/etc
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/netdata $(1)/usr/sbin
+ $(INSTALL_DIR) $(1)/usr/share/netdata
$(CP) $(PKG_INSTALL_DIR)/usr/share/netdata $(1)/usr/share
rm -rf $(1)/usr/share/netdata/web/images
rm -rf $(1)/usr/share/netdata/web/old
@@ -60,17 +79,8 @@ define Package/netdata/install
rm $(1)/usr/share/netdata/web/fonts/*.svg
rm $(1)/usr/share/netdata/web/fonts/*.ttf
rm $(1)/usr/share/netdata/web/fonts/*.woff
-
- mkdir -p $(1)/usr/lib/netdata
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/netdata $(1)/usr/lib
- rm $(1)/usr/lib/netdata/python.d/python-modules-installer.sh
- chmod 4755 $(1)/usr/lib/netdata/plugins.d/apps.plugin
-
- mkdir -p $(1)/etc/init.d
+ $(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/netdata.init $(1)/etc/init.d/netdata
-
- mkdir -p $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/netdata $(1)/usr/sbin
endef
$(eval $(call BuildPackage,netdata))
diff --git a/admin/netdata/patches/001-disable-plugins-by-default.patch b/admin/netdata/patches/001-disable-plugins-by-default.patch
new file mode 100644
index 000000000..6201046fd
--- /dev/null
+++ b/admin/netdata/patches/001-disable-plugins-by-default.patch
@@ -0,0 +1,26 @@
+diff --git a/collectors/charts.d.plugin/charts.d.conf b/collectors/charts.d.plugin/charts.d.conf
+index acb2a6f..8111859 100644
+--- a/collectors/charts.d.plugin/charts.d.conf
++++ b/collectors/charts.d.plugin/charts.d.conf
+@@ -30,7 +30,7 @@
+
+ # the default enable/disable for all charts.d collectors
+ # the default is "yes"
+-# enable_all_charts="yes"
++enable_all_charts="no"
+
+ # BY DEFAULT ENABLED MODULES
+ # ap=yes
+diff --git a/collectors/python.d.plugin/python.d.conf b/collectors/python.d.plugin/python.d.conf
+index 97f4cb8..001a3f1 100644
+--- a/collectors/python.d.plugin/python.d.conf
++++ b/collectors/python.d.plugin/python.d.conf
+@@ -7,7 +7,7 @@
+ #
+
+ # Enable / disable the whole python.d.plugin (all its modules)
+-enabled: yes
++enabled: no
+
+ # ----------------------------------------------------------------------
+ # Enable / Disable python.d.plugin modules
diff --git a/admin/netdata/patches/001-disable_external_plugins_by_default.patch b/admin/netdata/patches/001-disable_external_plugins_by_default.patch
deleted file mode 100644
index 629789247..000000000
--- a/admin/netdata/patches/001-disable_external_plugins_by_default.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/conf.d/charts.d.conf
-+++ b/conf.d/charts.d.conf
-@@ -30,7 +30,7 @@
-
- # the default enable/disable for all charts.d collectors
- # the default is "yes"
--# enable_all_charts="yes"
-+enable_all_charts="no"
-
- # BY DEFAULT ENABLED MODULES
- # ap=yes
---- a/conf.d/python.d.conf
-+++ b/conf.d/python.d.conf
-@@ -7,7 +7,7 @@
- #
-
- # Enable / disable the whole python.d.plugin (all its modules)
--enabled: yes
-+enabled: no
-
- # Prevent log flood
- # Define how many log messages can be written to log file in one log_interval
diff --git a/admin/netdata/patches/002-force-python3.patch b/admin/netdata/patches/002-force-python3.patch
new file mode 100644
index 000000000..9f7f731e3
--- /dev/null
+++ b/admin/netdata/patches/002-force-python3.patch
@@ -0,0 +1,12 @@
+diff --git a/collectors/python.d.plugin/python.d.plugin.in b/collectors/python.d.plugin/python.d.plugin.in
+index 7ac03fd..d0a3f19 100755
+--- a/collectors/python.d.plugin/python.d.plugin.in
++++ b/collectors/python.d.plugin/python.d.plugin.in
+@@ -1,6 +1,4 @@
+-#!/usr/bin/env bash
+-'''':; exec "$(command -v python || command -v python3 || command -v python2 ||
+-echo "ERROR python IS NOT AVAILABLE IN THIS SYSTEM")" "$0" "$@" # '''
++#!/usr/bin/python3
+
+ # -*- coding: utf-8 -*-
+ # Description: