aboutsummaryrefslogtreecommitdiff
path: root/admin
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2017-12-06 22:04:01 +0100
committerAlexander Couzens <lynxis@fe80.eu>2017-12-06 22:08:12 +0100
commit8d4814c26d057df4d271b0b65f7bd230344da6d1 (patch)
treea4d28a337290b1ec03490fcce32c115a3ef03128 /admin
parent52124bf283529661ddd39afdbea4283b44ea2b68 (diff)
zabbix: remove build timestamp
Build timestamp prevents reproducible builds [0]. [0] https://reproducible-builds.org/docs/timestamps/ Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'admin')
2 files changed, 14 insertions, 1 deletions
diff --git a/admin/zabbix/Makefile b/admin/zabbix/Makefile
index e5e61d1f3..af5044e08 100644
--- a/admin/zabbix/Makefile
+++ b/admin/zabbix/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=zabbix
PKG_VERSION:=3.2.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_HASH:=3ea0c299bd69bc728177128740f0476bc1a2c1de438330df5bbd8f5fc6090712
diff --git a/admin/zabbix/patches/110-reproducible-builds.patch b/admin/zabbix/patches/110-reproducible-builds.patch
new file mode 100644
index 000000000..f7d03fa9a
--- /dev/null
+++ b/admin/zabbix/patches/110-reproducible-builds.patch
@@ -0,0 +1,13 @@
+Index: zabbix-3.2.7/src/libs/zbxcommon/str.c
+===================================================================
+--- zabbix-3.2.7.orig/src/libs/zbxcommon/str.c
++++ zabbix-3.2.7/src/libs/zbxcommon/str.c
+@@ -51,7 +51,7 @@ static const char help_message_footer[]
+ void version(void)
+ {
+ printf("%s (Zabbix) %s\n", title_message, ZABBIX_VERSION);
+- printf("Revision %s %s, compilation time: %s %s\n\n", ZABBIX_REVISION, ZABBIX_REVDATE, __DATE__, __TIME__);
++ printf("Revision %s %s\n\n", ZABBIX_REVISION, ZABBIX_REVDATE);
+ puts(copyright_message);
+ }
+