aboutsummaryrefslogtreecommitdiff
path: root/admin
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2022-11-14 15:58:32 +0800
committerTianling Shen <cnsztl@gmail.com>2022-11-15 14:33:04 +0800
commit5671bd0d1aee30a86133aa350a6ca307af4f70e9 (patch)
treefc0885923f9d164c0f3c55ebfad88cf5fab92f61 /admin
parent409dbb05c9ea0877549e0f2536dd5efce1747048 (diff)
btop: append `--utf-force` argument by default
btop reads the `LANG` env variable to delect if the system has utf8 support, which exists on common Linux distributions. However, OpenWrt does not ship it, and results in btop reporting "No UTF-8 locale detected!". Users have to manually pass `--utf-force` to make btop happy. To make it OOTB, append `--utf-force` argument by default via alias. Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'admin')
-rw-r--r--admin/btop/Makefile3
-rw-r--r--admin/btop/files/btop.sh1
2 files changed, 4 insertions, 0 deletions
diff --git a/admin/btop/Makefile b/admin/btop/Makefile
index 557393d78..d1a986893 100644
--- a/admin/btop/Makefile
+++ b/admin/btop/Makefile
@@ -42,6 +42,9 @@ define Package/btop/install
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/local/bin/btop $(1)/usr/bin/
$(INSTALL_DIR) $(1)/usr/share
$(CP) $(PKG_INSTALL_DIR)/usr/local/share/btop $(1)/usr/share/
+
+ $(INSTALL_DIR) $(1)/etc/profile.d
+ $(CP) $(CURDIR)/files/btop.sh $(1)/etc/profile.d/
endef
$(eval $(call BuildPackage,btop))
diff --git a/admin/btop/files/btop.sh b/admin/btop/files/btop.sh
new file mode 100644
index 000000000..d7aa44760
--- /dev/null
+++ b/admin/btop/files/btop.sh
@@ -0,0 +1 @@
+alias btop="btop --utf-force"